Fail in transfer from Pancake Swap to Metamask

I try to Summarize in steps:

1 transfer BNB from Binance to Metamask “ok”

2 transfer BNB from Metamask to Pancake Swap “ok”

3 swap from BNB to COC token “ok” (I saw the actual amount of COC on Pancake Swap)

Then Pancake Swap asked me if I want to transfer COC back to Metamask as I said “yes” COC token were not on Pancake Swap nor on Metamask.

I know I did something wrong but I can’t understand what, is it useful to try to recover a screenshot of the transactions from Bscscan?

Thanks for helping

Hey @Omar_L, a screenshot would be helpful, but would you also be able to send a transaction hash? That would provide more information.

Keep in mind that swaps require two steps. The first step is to approve the token to be able to be swapped, and the second step is the actual swap for the tokens itself. Maybe you only approved your BNB, and still need to swap for COC?

Hi @nakedwinnie and thanks for the reply. When you say transaction hash, are you talking about this?
To me it seems like I did the swap, because I don’t have any BNB in my wallet

Yup, the transaction hash is the first on the list on bscscan.

It looks like your swap was successful and COC is in your wallet. Make sure you have imported COC as a custom token. Here is more information on our Knowledge Base:

Contract address for COC:

I did it already, but I see 0 coins in my wallet under COC

Ok, I solved it. It was easiest than I though, COC coins are in another account of my MetaMask; it’s just me and my poor knowledge of MetaMask, in fact as I’ve imported the COC token also in that address I saw them. I can’t understand why I started the swap from one address and it ended in another address (any idea?)

The funny thing is that I wrote to Pancake Swap official Telegram to try to solve my issue and after 2 seconds a scammer wrote me telling me that the problem was the synchronization of my wallet (!) and tend me a link to finally synchronize the wallet and solve the problem. I knew it was scam, but the word “synchronize” made me thing about the other address that I’ve created just to try MetaMask functionalities.

Any way thanks so much to @nakedwinnie for the support!


Glad the issue is solved! :slight_smile:

According to the screenshot you sent, it looks like it was the same address that started the swap was the same address the COC tokens were transferred to. As you stated, you were likely just on the wrong account.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.