How can I build metamask-mobile github code

Hello MetaMask Mobile Developers,

I am conducting research related to Ethereum development. As part of this research, I am currently in the process of debugging to understand the source code structure of the MetaMask mobile version.

We are currently debugging based on version 7.17.1 Release.

Here are some issues we have encountered, and we would like to inquire:

  1. We proceeded with the debugging process solely based on the file without any other reference materials. Are there any additional tasks that need to be performed at this stage? We encountered an error at the following step:
    $ yarn start:android

  2. During the $yarn start:android process, the INITIALIZING and CONFIGURING stages proceeded smoothly. However, an error occurred during the EXECUTING stage:

The error message is as mentioned above.

Thank you.

Hi thanks for sharing have you tried opening an issue on github: Issues · MetaMask/metamask-mobile · GitHub for this?

Thank you for the prompt response.
It appears that there are no issues based on the URL you provided.

  1. We are currently developing on the Windows operating system. Do we need to build on a different operating system?

The .android.env.example file looks like this:
What data should be added here for the build to succeed? If additional data is required, what values should be inserted?

The error we are facing is as follows.
$ yarn start:android

Task :react-native:ReactAndroid:hermes-engine:configureBuildForHermes FAILED

Task :app:createBundleProdDebugJsAndAssets
warning: the transform cache was reset.
Welcome to Metro v0.73.10
Fast - Scalable - Integrated

Hi sorry for the wait, please check react version what are you currently have?

We have the following version
react-native-cli: 2.0.1
react-native: 0.71.15

could you try to upgrade please and try again react-cli - npm react-native - npm

If react-native is upgraded, we will get an error due to mismatched dependencies while executing the yarn:setup command.
also, package.json file also states.
line 245 : “react-native”: “0.71.15”

I am currently using Release 7.19.1, and I ran it in the order listed in the file. (Development environment settings are complete.)

I uploaded the process of executing each command to build on YouTube.

If you have time, I would appreciate it if you could check it out.

  1. yarn setup (not error)
  2. yarn watch (error)
  3. yarn start:android (error)

The running environment is the Windows operating system, the development tool is using VS code, and the terminal is running with Git Bash.

Thank you for your continued interest.

Thank you so much for more details unfortunately I don’t have Windows handy I wouldn’t be able to reproduce it, is it possible for you to open a new issue: Sign in to GitHub · GitHub