Incorrect locale information provided -Can not open chrome extension

I am experiencing this trouble in my windows 10 PC and MAC with chrome 90.0.4430.93 and MetaMask 9.5.0.
" Try again by closing and reopening the popup, or contact support [这里]"

  • 信息:Incorrect locale information provided
  • 代码:RangeError
    RangeError: Incorrect locale information provided
    at new DateTimeFormat ()
    at r.getTranslatedUINoficiations (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:152:86362)
    at chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:152:410446
    at Array.map ()
    at w (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:152:410388)
    at ca (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:59367)
    at jl (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:104449)
    at bu (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:90053)
    at pu (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:89978)
    at iu (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:87326)
    at eu (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:84094)
    at zu (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:112010)
    at chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:113243
    at lu (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:87674)
    at Ku (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:113228)
    at render (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui-libs.js:75:115151)
    at chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/ui.js:152:1356094
5 Likes

I have the same trouble

2 Likes

Having the same issue here, cannot find solution anywhere.

Tryed removing extension, clearing cash and restoring account, nothing worked.

3 Likes

I have the same problem her, this start today.

4 Likes

I have the same problem, but on another pc it does not happen

4 Likes

I have the same problem. It began today after new verson 9.5.0

2 Likes

same issue since update

1 Like

Worked on the mozilla extension. Chrome still the same issue.

1 Like

Guys, I install old version 94 for Firefox from here MetaMask version history - 25 versions – Add-ons for Firefox (en-US)
and reinstall my wallet in firefox. Ir works!
I´m waiting for news about chrome extension

2 Likes

Mee Too, I use Iphone and works but in google chrome dont function

1 Like

Same problem here, I tried everything.

1 Like

Same here… I did everything

Firefox is working, Chrome and Brave not.

1 Like

same problem here…is it dangerous?

We are investigating this issue. Some users mentioned this article was helpful https://metamask.zendesk.com/hc/en-us/articles/360016336611-Revert-Back-to-Earlier-Version-or-Add-Custom-Build-to-Chrome

Another option from https://github.com/MetaMask/metamask-extension/issues/11033
A potentially quick and semi-nontechnical workaround is to set your browser’s language to a different language that is Intl compliant, like en (English), then reinstall the extension. Be sure that your seed phrase is 100% accurate, since reinstalling clears all extension data.

2 Likes

I am having this error, please help:
"Error Details

  • Message: Incorrect locale information provided
  • Code: RangeError"

Same problem here.
This start today.

here same problem,
started few hours ago
Error Details
Message: Incorrect locale information provided
Code: RangeError"

Yes , i have the same problem

Request [#159663]

same problem support request ([#159678]