Ledger Errors when sending

I am seeing two errors once I submit a transaction and the next step would be to approve on my ledger. They are: u2f device_ineligible or ledger_wrong_app then the transaction fails. I opened the logs up and it despite the site being connected correctly with the correct chain it grabs one of the other addresses I have in Metamask which are metamask not ledger so it is i gnoring my ledger for some reason. On the ETH chain I can send, validate, whatever but on any other chain I get the errors. Any idea why? Thx




It will go well :grinning_face_with_smiling_eyes:

Thx, I appreciate the help. Unfortunately, I’ve seen all that as I’m looking for a solution. I can use ledger for the ETH tokens but for example when I try and use ledger on Expanse chain I got it to work once by clearing the browser cache and the system cache then rebooting. But, that only worked once and I have no idea why. Despite being connected to the correct address and on the correct chain (expanse) metamask tries to grab another address within Metamask as it executes, not the ledger address . I see this in the logs

“invalidCustomNetwork”: {
“state”: “CLOSED”,
“networkName”: “”
“unconnectedAccount”: {
“state”: “CLOSED”
“activeTab”: {
“id”: 737,
“title”: “MetaMask”,
“origin”: “chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn”,
“protocol”: “chrome-extension:”,
“url”: “chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/home.html#new-account/connect”
“metamask”: {
“isInitialized”: true,
“isUnlocked”: true,
“isAccountMenuOpen”: false,
“identities”: {
“0x9ccf12ecb55d66ed841b99b66e25c1937721c46d”: {
“name”: “Account 1”,
“address”: “0x9ccf12ecb55d66ed841b99b66e25c1937721c46d”,
“lastSelected”: 1621798073465

Do you currently have the expanse app installed on your ledger? Expanse (EXP) – Ledger Support

Yep. I actually got it to work once after I cleared browser cache and cleaned system files/cache then restarted my computer. But that only worked once

when it worked before, what kind of transaction was it and how long ago was it?

I was using the expanse blockchain in metamask with the ledger withdrawing liquidity from a pool on their site eggs.cool

We are aware of this issue and am currently working on a fix to be released soon.
Thank you for your patience and understanding.
Please check this post for the latest updates.

these two errors (“u2f device_ineligible” or ”ledger_wrong_app” ) when trying to execute transactions with ledger on blockchains other than Ethereum (erc20 type tokens) this worked for me. Select the blockchain you want to work with in Metamask and ETH on ledger. It worked although I don’t know why. Occasionally I had to quit the ETH app on ledger than select it again to get it to work but at least it worked.