Ledger wallet can't connect Matemask and show " Looking for your Ledger"

I tried many times and changed three computer , I did with Metamask support information , but Failed . It show me “ Looking for your ledger" and didn’t entried next step

Can you help to confirm if you Ledger works on your Ledger Live app?

Sure , It works well on my ledger live app

What model ledger and browser are you using?
Were you following this guide https://metamask.zendesk.com/hc/en-us/articles/360020394612-How-to-connect-a-Trezor-or-Ledger-Hardware-Wallet ?

I have two ledger device Nano X and Nano S . I used chrome and microsoft Edge . I have done anything follow with the guide . I tried many times , all failed .

I’ve been having the same issue for weeks. I also see I get an error “u2f device_ineligible” or ”ledger_wrong_app” or it does nothing at all. The only time I was able to make it work was when I cleared browser cache cleared window cache/system files, restarted my computer. But it only worked for one transaction then went back to the above errors. However, today the errors are gone but it does nothing Sooo. If you solve this, please post the solution

I’m having exactly the same error here, starting just yesterday after I updated to Chrome 91.

All kinds of transactions were error “u2f device_ineligible”.
I tried re-connect the Ledger Nano S with the MetaMask, but it seems the Chrome extension could not find my Ledger.

BTW I just updated macOS 11.4 and Chrome 91 recently.

Hi all.
We are aware of this issue and am currently working on a fix to be released soon.
Thank you for your patience and understanding.
Please check this post for the latest updates.

hou to slove it my metamask visioin is9.6.1

This is still not working, any updates?

I also got same issue any solution?

I’m having the issue again. Suddenly I can’t sign transactions using metamask/ledger so they become stuck and I have to cancel them. The prompt on the ledger to approve doesn’t appear. Any ideas? I’m using Ledgerlive version 2.32.2, nano x build 1.30 Metamask 9.8.4 Chrome Version 92.0.4515.131 (Official Build) (64-bit). THx

This just started happening with me today too! Suddenly, transactions aren’t prompted on the Ledger anymore after clicking Confirm in Metamask.

I am using the latest Brave, Metamask 9.8.4, latest Mac OS. Ledger firmware has been updated to the latest, Ledger Live is closed, contract data is ENABLED, Ethereum app is open, tried restarting browser and computer, disconnecting/reconnecting Ledger, but nothing helps.

Can anyone please help?

same problem with Trezor

Same problem I’m currently having with Trezor

I ended up reinstalling an older version of Brave, and everything works now.