Ledger not reconized

HI Is anyone having issue with metamask and ledger nano x? When I try to connect metamask to my ledger the “Looking for Ledger” message constantly spins and doesn’t seem to be able to locate the ledger. I can however use the ledger with the ledger live app without issue. Does anyone have any ideas on how to correct this? This same issue exists with firerox, edge, brave as well. Thx for any help

Same question here . I have tried many time and changed three computers

We are aware of this issue and am currently working on a fix to be released soon.
Thank you for your patience and understanding.
Please check this post for the latest updates.

Nope it sure hasn’t. I’ve been searching for a answer and asking others. It looks like I’m not the only one having this issue

I am having this exact issue. It took me forever to find this thread, as my device was working perfectly 2 days ago. I didn’t realize Chrome updated, which also coincided with a Big Sur 11.4 update I just installed yesterday.

If you get in a pickle and need to access, this is working fine in Firefox v88.0.1

FYI I got it to work by selecting Expanse chain in Metamask but ETH app within ledger. That doesn’t make sense but that is what worked.

image002.jpg

It seems the issue was fixed in v.9.5.6, but later it occurred again in v.9.5.7.

According to the release note, your team would like to ‘Disable Ledger Live toggle for Firefox users’, but I don’t know why you also removed the function from Chrome release as well, so the connection is now stucked again on Chrome.