Metamask can't find my Ledger

Hey folks. Been working at this all morning. I’m trying to connect my Ledger to my Metamask for the first time (on Firefox), but the process keeps getting stuck on ‘Looking for your Ledger’ and the wheel keeps on spinning…

Steps I’ve taken:

  • Nano firmware is fully updated
  • Ethereum app is updated
  • I deleted and then reinstalled the Metamask Firefox extension
  • I cleared my browser cache
  • I restarted the computer several times

As best as I can tell, I’ve followed the steps correctly…here’s what I’ve done:

  1. connected Nano x via USB
  2. opened ETH app (blind signing is enabled)
  3. opened Metamask and clicked ‘add hardware wallet’
  4. choose ‘Ledger’…but then it just gets stuck on ‘looking for Ledger’ and the wheel keeps on turning.

The Ledger Live app is closed.

What am I doing wrong here?

Which method are you trying to connect to your MetaMask wallet? Have you tried with WebHID?

This article may provide more helpful information on different ways you can try connecting:

1 Like

I have not tried with WebHID b/c my Metamask extension doesn’t seem to provide that option. When I search around in the ‘settings’ it’s simply not there. Is it not available with Firefox?

Ah yea, try a different browser and connecting from there

1 Like

If I pair it with Chrome or Brave, can I then continue to use it with Firefox or will I lose that functionality?

You can connect on Chrome or Brave and won’t lose any functionality on Firefox.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.