Metamask renistaled but can't add the ledger

Hello everyone.

Before I reinstalled the MetaMask, my MM worked perfectly with the Ledger.
After reinstalling my MM, I cannot connect the ledger.

When I want to add the ledger, I cannot select my address. It is visible but not selectable. So I can’t set a check mark.
Here on the photo you can see that the check mark is already set. But the ledger is not connected. And I can’t remove the check mark.

Screenshot 2022-11-15 222020

When I make transactions, the request from the ledger does not come.
The transaction is processed but without the ledger.

I have now uninstalled and reinstalled MM for the second time. But it still does not work.
Thanks for your help

Hi @Leguani ,

Take a look at this article from Ledger and let us know if it helps!

3 Likes

Unfortunely this not helps.

Confirming you are on desktop/laptop?

What happens when you click “connect hardware wallet” here:

image

1 Like

I got two Ledger Nano and agree that some times it can be pretty hard to get the first connection to work. I had to do it many times over and over before it worked for me. I had to try different browsers before MM found my hardware wallets. I got it to work in Firefox and Edge, but never in Chrome. Maybe you could try in another browser ?

4 Likes

Hi @Leguani

You can also check to see if your browser permissions are on. Will leave a screenshot here with the guiding steps:

3 Likes

Yes, I am on a laptop.
After I click on connect hardwallet, I come to this menu

After clicking on the ledger symbol this menu appears

Ledger

there is my address with a check mark in the first place. That means the ledger is linked, but it is not. And I can’t remove the check mark.

I am on firefox. So far it has worked without any problems.

@Leguani ,

Please reach out to our help desk team. You can access Help Desk through your browser extension or mobile by going to menu > support > choose ‘Start a Conversation’ blue bubble. Or, you can go to support.metamask.io and click the blue ‘Start a Conversation’ bubble.

Remember that nobody, including support, should ever ask for you to provide or verify your Secret Recovery Phrase (SRP). They also will not ask to connect to your device. Never share your SRP, this includes never inputting it on a form or website (including pop-up windows).