Ledgers cant connect

I have 3 Ledgers that i have used for the past 6 months daily. They were all working fine up until i tried them a few hours ago. All 3 of them cant connect to MetaMask. When i try any transaction on any chain i get a grayed out ‘CONFIRM’ button which isnt clickable.

I have updated everything (LEDGERS, LEDGER LIVE, MetaMask, BROWSERS). Ive tried using Chrome, Brave, Firefox and Opera but i cannot connect. I have installed MetaMask on all those browsers but when i click on CONNECT HARDWARE WALLET, all i get is LOOKING FOR LEDGER and it doesnt connect.

I know nothing is wrong with the Ledger or connection because i can connect with Ledger Live on all 3 Ledgers.

Does anyone have a solution. Again this issue just popped up just hours ago. before that i had no problems using my Ledgers. Hope you guys can help me out. thanks.

2 Likes

OMG! same with my problems! I don’t know what to do anymore, I updated all browsers/ new browsers/ tried 3 computer but still my ledger nano x can’t connect. When I tried to change my “Preferred Ledger Connection Type” in MetaMask tab, changed it to WebHID or Ledger Live, the screen of MetaMask will get Stuck on loading thing.

what is happening please help.

1 Like

@crusty are we the only ones having this kind of problem?

1 Like

Hello @stephenperry18 and @crusty, welcome to MetaMask community!

It would be best if you contact Support team at https://metamask.zendesk.com/hc/en-us and click Start a conversation

support

Once you click Start a conversation a live chat bot will appear on your screen. It will give you an automated response at first, but afterwards you should be able to contact the support team directly.

1 Like

thanks so much! appreciate the help.

3 Likes