Metamask doesn't find my ledger


I’ve been using my ledger through Metamask for something about 3 months now, with no issues at all, but since friday last week, Metamask doesn’t recognize ledgers anymore

At first, MM stated that I wasn’t in the ethereum app (even if I was), and now, MM doesn’t even detect my ledger

Even when trying to connect a new hardware wallet, the process keeps getting stuck on ‘Looking for your Ledger’

I can’t sign any Tx now, this is a bit annoying when you DeFi a lot

What I’ve tried so far:

  • Nano firmware is fully updated
  • Ethereum app is updated
  • I cleared the browser cache
  • I restarted the computer several times
  • I deleted and then reinstalled the Metamask extension
  • I tried a couple different browsers
  • I tried with an another brand new ledger/cable
  • I tried with an another PC
  • Followed the article metamask-and-ledger-integration-fixed

I’m running out of ideas, I think the issue might come from the browser just like in may, broken connectivity when browsers made some updates

Any ideas ?

Hi Sorag -

Have you checked out some of the articles on the ledger site? Here is one that I’m going to copy and paste info of below, I realize you’ve gone through many of the steps but there were some additional ones…might help? If not, let me know and I can keep trying to dig.


In this article, you will learn a few tips that can help you connect your Ledger device to Metamask .

Most Metamask connection issues can be avoided by following the tips below.

Please go through each item carefully then try connecting your Ledger device to Metamask again.

*Chrome users can manually force an update by going to - Manage extensions > Developer mode>Update

Also - love the lucharores pfp!

KBee (does not work for MM, just trying to help!)



Thanks for your reply

Yes I already checked out some of the articles on the ledger site, but I can’t find one relevant for my situation

I already tried Brave, Chrome and Firefox, doesn’t work

1 Like

Hey @sorag, welcome to the MetaMask community! :fox_face:

Have you tried a different connection method, such as with WebHID or Ledger Live?


Hi @nakedwinnie , yes I have already done that

So many issues with Metamask (and so little improvements), I guess I will switch to Frame, since you can impersonate Metamask with it

Sorry to hear the issue continues :slightly_frowning_face:

If you would like, you can reach out to our support team at and click Start a conversation

Well I’m using Frame now, wayyy better than Metamask

There is way too much issues and not enough innovations with Metamask, which is incomprehensible regarding your funds and the number of your engineers

You can’t even import an hardware wallet without creating a seed first

Thanks for everyone who tried to help, but I’m definitely switching for Frame, bye old and outdated Metamask

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.