Can't move assets from Ledger account in Metamask

I created a hardware account with ledger on my Metamask account and send assets to it. Now i can’t tranfer assets to my other account, i can’t seem to connect my Ledger to MM. I’ve got Ledger live installed but when i try to connect i can’t tick the box of my Ledger account.

1 Like

In metamask, under advanced settings, check the ledgers connection type (its near the bottom)
It should be in “HID mode” (thats the new method we use, dont need to use the LedgerLive software to bridge the connection anymore) you can swap it to “LedgerLive” mode here if the HID mode is giving you trouble.

Update the firmware (this happens through LedgerLive), the browser, and extension.
Then on the ledger itself, make sure the device is connected, unlocked, and the Ethereum app is open (will say “application is ready” on the devices screen)

When you click “connect hardware wallet” in metamask you should get a screen like this:
Screenshot (14)
Click the devices name, then connect, and you should be good to go.

When you send a transaction, keep an eye on the ledger itself. Final step is to confirm them from the device.

Thanks a lot for your reply. Unfortunately i can’t select ‘HID mode’ in my MM account. At advanced settings i can only select ‘Ledger live’ or ‘U2F’.

I don’t see that black screen ‘Metamask’ wants to connect to a HID device either.
When i click ‘Connect hardware wallet’, i select ‘Ledger’. Then when i hoover over the created hardware wallet it’s showing this:
‘This account has already been connected to Metamask’

Now a new message is showing: Ledger device: UNKNOWN_ERROR (0x6b0c)
But that might be due to the changes settings?

It seemed you’ve helped this guy out, i’m suffering pretty much the same issue i guess.
It won’t bring me to this pop-up screen where i can select my device…

update the ledgers firmware, update the browser, and update the Metamask extension.

If you don’t see HID mode listed, you’re on an older version of the browser or the extension.

That error (0x6b0c) is a known issue with older firmware:

1 Like

Firmware is up to date: 2.0.2

This message is showing in my Ledger live, should be ok i suppose?

Google chrome is up to date as well.
The version of metamask is:
MetaMask Version 10.9.3

Can Metamask be updated or is this the latest version?

I found a way to update MM:
MetaMask Version 10.10.0

What a pain this is, i still can’t get connected to my Ledger account in MM.
I’ve updated MM, did the whole list as below, even did a reset of MM account.
Still no connection. Why does that pop-up is not showing up?

Can’t get any further than this…

I still can only select ‘U2F’ or ‘Ledger live’ in Settings → Advanced
HID mode is not listed

Could the problem be that the assets are in my BSC network?
Does it not work with Ledger?
When i search in Etherscan my assets are not showing which are in my hardware account on the BSC, they do show up in my Metamask account though but i just can’t reach them.

The address is the same of the Ledger account, both ETH and BSC.
But only the assets of the ETH network are showing in the Etherscan.

You won’t be able to see your assets on BSC on Etherscan because Etherscan is only for Ethereum mainnet. You can use to see your assets and activity on BSC.

Are you trying to connect while your MetaMask wallet is on Ethereum mainnet or BSC? If it’s on BSC try connecting on Ethereum. Make sure that your Ledger is also completely plugged into your computer, not halfway in.

1 Like

Hi there,

Yep, got ‘Application is ready’ showing on my Ledger device.
MM set to main network but still can’t get it my account.
What am i doing wrong?
Please find attachment, the box of the account is ticked but can’t be selected.

Schermafbeelding 2022-02-23 om 19.55.23

Try it through the extension icon, rather than in a tab on expanded view.

This previous post of the same issue may also help:

Interesting issue you’ve mentioned. Several persons suffered the same issue.
The checkbox of my locked hardware account is checked, but it’s grayed out and can’t be unchecked. I can’t see a way to work around it.
I just don’t come that pop-up screen where i can select the Nano device as attached below.

Would reinstall MM be an option to solve this issue? Are there risks of loss of assets then?

Screenshot (14)

I’ve moved assets from Ledger live to my MM account without any problems, so at least i’m sure my Ledger device is working fine.

The only problem is to connect my Ledger device with MM, so frustrating…

It seems a few persons suffer the same issue.

Help me out to walk through the log-in steps to figger out where it goes wrong:
-I connect my Ledger device to my computer ->Application is ready
-Blind signing ‘Enabled’
-Unlock metamask
-Switch to main network
-Click on connect hardware wallet
-Select the ‘Ledger’ option and click ‘Continue’
-Then i end up as the screenshot attached with the greyed out ticked box.
That account i need to connect, that is my created Ledger account.

But the connection should be possible without Ledger live, correct? The (black) screen where i can select my Ledger is never shown op popped up.

Could this be a reason of this failure?
I’ve noticed that the Ledger live app is showing version ‘Firmware is up to date: 2.0.2’
On my device is showing ‘Version 1.9.17’

I’ve tried searching but i can’t find any information how to update only the device itself. Only the Ledger live can be updated which is up to date

As long as you have your correct Secret Recovery Phrase, you will not lose your assets on a reinstall. As an extra safety precaution, you can also download MetaMask on another device with your Secret Recovery Phrase.

Correct, connection is possible without Ledger Live, such as with WebHID. If you are connecting without Ledger Live, please make sure you have Ledger Live closed.

You should be able to update your Ledger firmware through Ledger Live Manager :point_down:

What happens when you try to click on the checkbox or any other checkbox?