Metamask - Ledger Nano X - JSON RPC error

I tried to connect my ledger nano X to metamask but I got an error JSON RPC.

Both chrome and Firefox gave me the same error. I was doing this on a Mac. I tried changing the network to local and test nets as well, still nothing works.

Any ideas on how to fix this issue?


I have the same issue. Still not know how to solve it.


Same issue here, brand new mac air M1 and new ledger X. Latest firmware, followed all available troubleshooting guidelines, tried different cables, uninstalled and installed, restarted, different networks. Giving up

1 Like

I am having the same exact issue, tried all the updates with ledger, eth app, chrome, and metamask. they are all up to date. it has to be a bug with metamask because going through ledger live still works, can send and confirm a tx. I cannot connect to my previously connected metamask, so i tried uninstalling the metamask and reconnecting and now i can’t connect at all with metamask browser extension.

need a response

1 Like

I’m having exactly the same issue here, starting just yesterday after I updated to Chrome 91.

All kinds of transactions were error “u2f device_ineligible”.
I tried re-connect the Ledger Nano S with the MetaMask, but it seems the Chrome extension could not find my Ledger.

BTW I just updated macOS 11.4 and Chrome 91 recently.

1 Like

Hi all.
We are aware of this issue and am currently working on a fix to be released soon.
Thank you for your patience and understanding.
Please check this post for the latest updates.

1 Like

My Nano X works on my windows laptop with Chrome, a bit clubky but gets it done and I was able to add to metamask. However, on my new macbook air m1 the issue persists. JSON error in chrome but ledger live works well.

I’m having the same problem, trying to deposit ETH into a staking contract and it is failing. M1 Mac Air, tried both Firefox and Google with the same results.

Closest I got was seeing the ‘select an account’ dialog, which had my Ledger account ticked, but the Unlock button is greyed out, and nothing I did would enable it.

Have followed the checklist at articles/360020394612-How-to-connect-a-Trezor-or-Ledger-Hardware-Wallet so everything should be correct

Any suggestions?

Update: I solved the problem by using Chrome and using the bridge to Ledger Live. To enable this, In metamask go to Settings: Advanced and scrolled down to the switch for Use Ledger Live