Can't connect Ledger to Metamask - Internal JSON-RPC error

Hello,

I am using Macbook with Metamask Chrome Extension.

I have a problem with Ledger and Metamask. Basically when I tried to make a transaction yesterday, approved it in Metamask, my Ledger didn’t show any transaction details. There was no reaction at all. I tried few times to unplug it and plug it back, tried to make few other transactions, reset my Metamask account, tried different USB port - no success.

I tried as well to clear the cache in the browser, used different browset (Brave) - no success.

I created a different Metamask account and I can’t even pair now my Ledger with Metamask. Seems like Metamask it’s not detecting Ledger at all (USB port is working fine, Ledger is charging). The following warning appear in Metamask:

“Internal JSON-RPC error”

I am running out of ideas. Couldn’t find any solution in internet.

Two days ago everything was working fine. Yesterday I updated Chrome to the latest version - I suspect that this update might have caused some issues.

Can you please help me out with this?

5 Likes

I have same issue but with a Windows PC. Same Error and no way to find how to resolve.

i had the same issue. connect ledger via usb with the pc. disable bluetooth. select poweroff (should instantly restart when connected via usb). open ethereum app. try again. that worked for me.

Did you ever find a solution for this? I am having the same problem and can’t figure it out. I have tried all of the options listed below.

2 Likes

I had the same problem and solved it by opening the Ethereum app on my Ledger before trying to connect it to MetaMask.

If I am not mistaken, this is a issue with the last version of Chrome. As Brave is based on Chromium, it may present the same issue. Try with Firefox, it worked for me.

Microsoft Edge is also based on Chromium, so it may present the same issue. The only browser with Metamask which is not Chromium-based is Firefox.

hello!

using mm & ledger nano x for a while now without any issues… always on brave.
since yesterday i have the same problem… brave was updated… turning off bluetooth, updating firmware, updating mm didn’t work for me so far…

to me this is a new issue i never had before. and its the worst possible timing bc instead of being able to sell some of my positions on a high… i have now lost quite some money bc of this…

Same issue here using Ledger Nano S, laptop Win7 and Brave. However I could connect on a different laptop running Win10, which rarely connects to the internet (it’s backup).

image
This might be the answer we are looking for.

1 Like

thx man! hope it works man! already lost 1/3rd of my profits for DFYN…

If I go to Settings > Advanced in MetaMask using the latest version there is no ‘Use Ledger Live’ option.

1 Like

metamask has to be version 9.5.7.

settings → advanced → about (for version)

Yes, latest version 9.5.7 installed. No option to ‘Use Ledger Live’ in Settings > Advanced as noted by other users.

3 Likes

Fix this please

No option on 9.5.7 using latest ubuntu and chrome for the ledger liive

Do you even test along with the chromium releases?

Clearly too big for your britches.

1 Like

I have the same issue… costing me $$ as i cant access farms.
Using Mac with Brave and cannot connect to Ledger for over 24hrs++.
There was no news anywhere… caused alot of unwanted stress until i found this feed.
Please fix this issue and Ledger… please communicate with us!

1 Like

Yep, i have macbook pro and try to connect ledger via chrome and brave. No success.

“Internal JSON-RPC error.”

1 Like

By Firefox works perfectly.

i re-installed mm yesterday. the option was the last in the “advanced” menu. i checked and its gone now.

???

i had everything set in on brave… worked fine till the update.

now i cannot enter my ledger on the defi platforms i use! sollet not working in firefox either… this costs a lot of people $$$

Hello

Anyone managed to solve the issue ?
not working for me, and cannot find “Use ledger live”. I confirm i got 9.5.7 metamask , and chrome & brave are updated to last version.

Becomes REALLY URGENT GUYS !!!
thanks