Can't connect Ledger to Metamask - Internal JSON-RPC error

same here
did you find something ?

Guys this is a problem with brave and Chrome, just use Firefox and you will be good!

1 Like

Hi metamask, how do we solve this problem. I try using firebox instead of chrome but its still showing me internal JSON - RPC Error

Yesterday, errors on Brave and Firefox (latest versions of all including MetaMask). Reinstalled Firefox and MetaMask this morning with success. Ledger working again, recognised and signing transactions (MacBook Pro Big Sur 11.4).

Worst experience with any wallet, MM is subpar!

I’m hoping you found a solution and can share it here.

I just received Ledger Nano X and trying to connect with Metamask.
Please fix this. I’ve tried Brave and Firefox but nothings work for me.
There’s also no Connect Ledger Live button in my extension.
PLEASE FIX THIS

Has anyone try the Guarda Wallet as an alternative?

The option was there on 28/5 but not it’s disappeared again.

Still not working for me. I even downloaded firefox but it returns the same JSON RPC Error. Please fix this. I can’t do anything. The option enable “Ledger Live Support” is also not available.

Same issue in chrome, brave and firefox. Also no option to enable Ledger Live support.

2 Likes

I could not get Chrome 91 and MetaMask 5.7.1 working because of missing Use Ledger Live option. However, I got it working for Firefox.

Here are instructions on how to fix this and get Ledger working with Firefox and MetaMask.

This doesn’t work for me.

MacOS / Firefox version: 88.0.1

Truly unbelievable that a fix is taking this long

Same here.

I use Ubuntu Linux and since Chrome auto-upgraded from v90 → v91 I’m having no luck using my Ledger Nano X with MetaMask. Everything was fine before.

I checked my MetaMask version is recent: 5.7.1.
I checked “Contract data is allowed” in the Ethereum app settings on the Ledger device.
I checked the ETH app on the Ledger device is up to date
I checked that the Ledger Firmware is up to date.

I do not see a “Use Ledger Live option” in Settings > Advanced.

I installed the Brave Browser but had no luck. Same results as Chrome.

The good news, is that it worked when I tried FireFox. :heavy_check_mark:
I used Firefox Browser, v88. I noticed the MetaMask Version is a bit behind (9.5.5).
With Firefox I got a bit further and MetaMask on Firefox does connect to the Ledger.
The “Transaction Approval” message does show up on the Ledger.
At first when I Approve the transaction it fails with a error message:

Transaction failed with the reason: Error: TransportStatusError: Ledger device: Condition of use not satisfied (denied by the user?) (0x6985)

But when I closed all other applications, and restarted FireFox, and tried a different transaction from the one that was failing. It went through fine. :heavy_check_mark:
I have now made several successful transactions using FireFox with MetaMask and my Ledger.

1 Like

Ledger does not connect to Firefox on MacOS.

Firefox v89.0
Metamask v9.5.5

I was able to get Firefox, MM, and Ledger to work as well. However, it does not appear that MM version 9.5.5 supports Polygon network. Has anyone been successfully in adding the Polygon network manually?

I was able to use L2 just fine with both MATIC and Optimism with Firefox!

I can confirm FireFox with MetaMask version 9.5.5 supports Polygon network. I used it on Quickswap just an hour ago.

1 Like

Yes! It works now! MetaMask has that advanced option to use with Ledger Live. That setup works great. Using latest version of Chrome too.

Thank you all, to check the status update for this issue, please refer to this Ledger Connection Issues