Metamask app on Iphone not working good with walletconnect

Hello, I’ve created a Dapp that uses a smart contract on Mumbai and NFTs minted on Open Sea.

So the user has to approve the smart contract to stake the NFTs. The MetaMask app on Android and MetaMask extension on PC work properly, but MetaMask app on IOS doesn’t work. An unknown RPC error occurs when approve methods is called. The Dapp uses WalletConnect V2 (Version: viem@1.4.1) library to connect the wallet.

Anyone has any idea why? Thank you.

1 Like

Hi could you confirm if you are using MetaMask sdk: Set up MetaMask SDK | MetaMask developer documentation

1 Like

No, I’m using WalletConnect V2.
I tried on 2 Iphones and didnt work. I’ve change the Mumbai Rpc url and both of them and the problem on one of the iphone was solved. But on the other one still not working.

Yes. Same with me. My wallet lost with some big amount. After enter phase it no wallet there
Hi im using metamusk in iphone. I have 6 wallet in metamusk but now it lost. Im entering 12 phase but it not they too. My active wallet important to me. But now after entering secret phase its not recover my old wallet. All my wallet below its lost. It shocking now. Plz help

Can anybody help me

Hi @qahhaar please don’t share your wallet addresses I’m removing them for security, try this article :

In addition, please use Support section for questions about MetaMask wallet, thanks

Hi @calin77 thanks for more details, have you talked to WalletConnect support, not sure what you are trying to do using WalletConnect with MetaMask? Maybe you have some documentation to reference, thanks

I dont now how to tell. All document are still have but my wallet still not in

If you like please open a conversation using this link click the blue Start a Conversation button

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.