MetaMask can't connect to Trezor - Manifest not Set

For a few days now I can’t connect my Trezor to MM. I uploaded several versions of MM, now using the latest one, I made sure my Firmware and Bridge for Trezor are up to date. I cleared the cache, turn off my PC several times, changed browsers, and even updated to Windows 11.
I have no ideas what I should do now to fix this issue, could anyone help?
Thank you in advance!


Hello @Lana22, welcome to MetaMask community!

This is more of a Trezor related issue from what i remember, as recent updates of MetaMask solved the issue on MetaMask’s side. Have you tried another pc, to check if it’s something locally on that respective one on which you tried? Make sure the other pc/laptop is yours or you can trust it.
Also, could try getting in contact with Trezor support.


Hi @Chinzilla, Thank you very much for taking the time to help me with this issue!

It’s only on my PC indeed, and I thought it would be on the MM side since I am not even touching my Trezor ( when I go on ''connect hardware wallets" with all the wallets a pop up opened except for Trezor and an error message appears: Manifest not set trezor/connect/blob/develop/docs/
As you said, I saw on Reddit that someone had the same issue but it was solved just by a restart PC or the new version of MM. I feel like I have tried everything seriously, and also it works a day, and then suddenly it doesn’t work again, so frustrating. I am in contact with Trezor support but they said it is on MM side, but I will insist a bit more.

If you have any other suggestions please let me know ! :pray:


hi @Lana22 ,

What browser are you using with your MetaMask extension?


Hi @KBeeTheCapybara
I am using Chrome Version 108.0.5359.95
I also tried with Brave and with Firefox but same results :confused:


@KBeeTheCapybara after answering your question, I was like ok maybe give it another try with Firefox ( I tried like 4-5 times with uninstalling MM there too) because I made the update of Windows during the night, so I thought ok this could have helped somehow… and yes!
I have had this issue since Thursday and really started to get desperate! My problem isn’t completely solved but at least I have this option now. Thank you very much for answering my msg guys! If Trezor or MM support give me the reason later and fix my problem with Chrome I will update this post too !


This topic was automatically closed after 30 days. New replies are no longer allowed.