Metamask Detected Wrong Nonce - Can't send without Changing Nonce

Hello All,

I am having a problem with sending any kind of transaction using MetaMask on the BSC Test Net. I can still make transactions but only if I am using a custom nonce.

What created this problem was that MetaMask had a pending transaction that went through.

MetaMask thought it was still pending. The BSC Testnet transaction this happened on was 0x68b814810acf199c75152e9f3e74755d3d8c36e07d805ca64970641e2f763c66

You can also see from my account 0x0C2a98ace816259c0bB369f88Dd4bcb9135E0787 I am able to make more transactions.

But when using MetaMask automatically it is detecting my nonce as being 550. When making a transaction the error is

replacement fee too low (error={“code”:-32603,“message”:“Error: [ethjs-query] while formatting outputs from RPC ‘{“value”:{“code”:-32603,“data”:{“code”:-32000,“message”:“replacement transaction underpriced”}}}’”,“stack”:“Error: Error: [ethjs-query] while formatting outputs from RPC ‘{“value”:{“code”:-32603,“data”:{“code”:-32000,“message”:“replacement transaction underpriced”}}}’”}, method=“sendTransaction”, transaction=undefined, code=REPLACEMENT_UNDERPRICED, version=providers/5.0.24)

How can I get MetaMask to “resync” to the correct nonce so I don’t have to put in a custom nonce each time?

I have already tried…

  • Resetting my account.
  • Removing MetaMask and reinstalling
  • Moving to a new browser and importing this account.

Perhaps this is not a metamask specific problem? But how can I go about finding a way to solve.

1 Like

Watching. I have the same issue intermittently. Seems to resolve itself eventually but I can’t reproduce how.

Same issue. for transfering USDC outside of metamask, swapping VRA … I can’t do anything with my metamask now. (browser and app)
I tried to

  • reset the account
  • wait a few days
    … do not know where to look for a solution

Hey @Mapppa, welcome to the MetaMask community! :fox_face:

Please create a new topic for your separate issue :slight_smile: