A pending transaction now turned into a nightmare. PLEASE HELP

I had unstaked an NFT 3 hours back, it was initially stuck at pending for nearly 10 minutes. Remembering that i had switched on ADVANCED GAS CONTROL a day prior, I thought this may have been the issue so I tried to speed it up and after waiting another few minutes I tried speeding it up again.

TXN Hash: 0x34c7c07893a1f3391d795999cadd8cd0503605c4bf680fa49f05f1d40a98caad

But after a few minutes later, the NFT eventually appeared on my opensea page, yet the transaction still appeared pending in wallet. Now i was trying to get this transaction to stop appearing ‘Pending’ since i was afraid that it will take more gas from me. So I tried sending myself 0 eth using same nonce as previous (not sure if i did this right) and eventually resorted to reseting my wallet.

Now i cannot make any transactions using eth in my metamask. Whether its trying to list, send money to myself it’s failing. If i try to buy a NFT or list, there is a message that reads.

MetaMask - RPC Error: Error: [ethjs-query] while formatting outputs from RPC ‘{“value”:{“code”:-32000,“message”:“replacement transaction underpriced”}}’

The failures are not showing on blockchain. Only on the devices that i tried doing these transactions on (laptop and mobile). I have even set the gas on these transactions to the highest suggested settings only for it to fail immediately. Please help, I really need the metamask to get back to its functional state again. I’ve looked and can’t seem to understand how to fix this.

Thanks in advance

i known it.
you must reset account.

Do not trust any one person in one message.
Please always check many information to double check.
will be safe in the crypto world

If my answer helped you,
please like (heart).
:slight_smile:

I have resetted my wallet. I have had issues ever since do so.

1 Like

The rest account

It is clear pending transection about not enough

Cause problems to The next transection not be sent.

After clear it

If you have gas

You in normal state

If my answer help you please like. :slight_smile:

Hi thanks for your reply. I resetted once from my mobile phone and once on my laptop, it did not work. There’s still a pending transaction from when I was trying to approve when trying to fix it after initial problem.

Hash from Initial problem on laptop wallet:
0x34c7c07893a1f3391d795999cadd8cd0503605c4bf680fa49f05f1d40a98caad

It appears I still have a pending transaction from when I was trying to fix it using my mobile as well.

Resetting didn’t work. I really need help

Wait. For mod or admin to answer

I dont know

Ok. Thanks for trying though. :slight_smile:

Issue resolved by making sure that the right Nonce was used. Tip for those who encounter this in the future, use your mobile phone. I tells you whether the Nonce you are trying to use is out of sequence. I was trying to use my laptop all this time, obviously I used the wrong Nonce.

Mod/Admin, you can mark this issue as resolved if needed

2 Likes

Hey, I’m having the same exact issue. The problem is I’ve tried to reset as well, tried looking for the transaction that gave me a problem too but cannot find which one it is. I thought I had it prior , I tried to send myself a transaction to my own wallet with that Nonce number but that didn’t even go through. I deleted the extension from my laptop browser and reentered the seed again. There is one pending still from 4 hours ago and another one I tried right before i deleted the extension. Really aggravating. I really could use your help here.

I am having the same issue. Pending transaction from 7 hrs ago and since I keep getting failed transactions with this message. [ethjs-query] while formatting outputs from RPC ‘{“value”:{“code”:-32000,“message”:“replacement transaction underpriced”}}’
I have reset, done the eth transfer transaction to same nonce of pending transation with MUCH higher gas and same error message occurs. It’s like it won’t even get to blockchain now to fix the clog. Can’t mint or transfer NFTs. I can receive eth but that is it. I set up metamask in new browser and no different. Will this clear itself over time? No fixes seem to work. Please help!!

Ray, I spent the entire day ripping out the hair on my head. Go to Metamask support, at the bottom the page go to start a conversation. Explain yourself, if it don’t help you, you’ll eventually end up on the chat with someone, in the end, downloading metamask on a new browser and paying high gas fees in a new browser with the correct nonce did the trick. Good luck

Hey you guys still having issues? I was too ripping my hair out and spent close to 8 hours trying to fix it. I suggest trying the Nonce method on your MM wallet on mobile. It will tell you that your nonce is wrong if you’re trying to use the wrong on.

For context, I thought u was suppose to use nonce 188, tried 187, 188, 189 on my laptop without any message from wallet saying it was wrong. But the moment I tried doing it on my mobile wallet the prompt told me the nonce was wrong and wouldn’t let me continue without selecting “guessing” the right one. It ended up being nonce 191 for me. It’s back to normal now

Hey, see my msg. I noticed there were couple replies to this and wanted to come here to help. I hope it helps

Hello, same problem due to the same steps. I don’t know which transaction is hung because I reset it. Reinstalling Metamask did not help, the mobile application also gives errors. If I put a nonce that has not been previously used, then the transactions go to the waiting queue. Metamask support not responding

in which browser did you download Metamask? please tell me more

Ray go to metamask support, then bottom of the page to start a conversation. You’ll fill out what’s wrong and it’ll ask did this solver you problem, I said no, then eventually they start a chat and wait for a tech to jump on. Be patient, they walk you through everything. Make sure you have enough ETH in the account to spend on gas. They’ll be able to check etherscan and see what to do next.

1 Like

thank you. I will try as you say

1 Like

Solved a problem. For those who have a question that can increase the amount of GWEI. Moreover, you need to enter the maximum value in two columns (Max priority fee, Max fee), and put the Nonce number of the transaction that hung first. Thanks to all

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.