Bug etherscan/metamask (Pending from >24h)

Hello,

It has been 24h since I have a pending transaction on MetaMask and on etherscan, this is my address: Address 0xFaF78a15E2a03aB6B38a1612490B10AAe125244B | Etherscan

There are two transactions, the second one which is the one that blocked everything and the first one I tried to do to unblock the situation but nothing…

I tried speeding it up, canceling it to send me something to unblock but still nothing…

I tried from trust wallet to send me a transaction with nounce=0 which is the one from the second transaction but trust wallet won’t take me a nounce=0 or =1… and even from MetaMask with all the advanced settings I can’t find the option nounce…

I thought after 24h it would reset itself but still nothing…

I also tried resetting MetaMask and try to do a new transaction but still nothing, below you can see what I get…

Schermata 2022-11-10 alle 09.15.19

I also tried a few minutes ago to send me two transactions one with low fees and one with high fees but still nothing…

I don’t know what to do anymore, could you please help me ?

Thanks in advance :pray:

1 Like

Hello @JRose, welcome to MetaMask community!

This is how you can fix your issue. Please read the articles and let me know if they helped, if possible.

6 Likes

Hello Chinzilla,

I tried your guidance but I still have problems…

  1. I select the amount to send, first I tried 0 and then smaller amounts

  2. I set all fees higher than recommended, these are some examples



  3. I set the nounce = 0 as in the transaction hash ( Ethereum Transaction Hash (Txhash) Details | Etherscan)


  4. Always the same error…

What am I doing wrong?

Hi @JRose
Try to set the values for the Max base fee and Priority fee without the 0 in the front and see if the transaction goes through. So instead of 070 or 02 just type in 70 or 2 as an example. And always check the gas fees on the networks gas tracker 66 Gwei | Ethereum Gas Tracker | Etherscan

2 Likes

I just tried several times but it still doesn’t work… :frowning:

I’m not sure if switching to another browser or using the mobile app will work.

The gas is relatively high these two days, and it may automatically succeed when the gas comes down.

2 Likes

In the first transaction that needs to be replaced, the one with nonce 0, the MAX fee was 10gwei and MAX priority 2.5gwei. Now, can you give it a try following these instructions?


But just like @tuya mentioned, gas prices are quite high at this moment, the Base fee is fluctuating between 30 and 54 gwei.

3 Likes

Update: I tried to made a transaction to myself from the same address and the firs pending transaction disappeared, then I tried with the same method for the second transaction with nounce=1 but nothing… Then I tried with other two address but always the same errore : Transaction 0 failed! [ethjs-query] etc…

I will try when gas fee are lower, let’s hope well :crossed_fingers:

1 Like

I just checked on etherscan and the transaction with Nonce 0 was replaced and the one with Nonce 1 has the status Dropped & Replaced, so I assume it should be fixed soon.
In the second self transaction that you made your fees were Max: 60 Gwei |Max Priority: 1.7 Gwei, but on the gas tracker it shows that for Max priority you should have at least 2 :frowning:

3 Likes

Also, always check the gas prices on the gas tracker before initiating new transactions 43 Gwei | Ethereum Gas Tracker | Etherscan

3 Likes

Resolved! Finally the second transaction was enough, I reopened the scan now and did a swap and everything works! Thanks for the help everyone :slight_smile:

7 Likes

Oh, that’s great! glad we were able to help.
And thanks for taking the time to let us know it worked :slight_smile:

3 Likes