MetaMask Mobile - Invalid amount

There seems to be a bug in MetaMask mobile app and I found a lot of topics with this problem, but all topics are closed with no solution. I already contacted support (agent conversation) and they redirected me to forum and forum redirects you to agent converstation? I think that MetaMask team needs to be aware of this, since there IS a bug in mobile APP.

You can see detailed description of problem here: (https)://forum.moralis.io/t/metamask-invalid-amount-in-metamask-app-on-iphone/14363/20

Other topics about that problem:
(https)://community.metamask.io/t/metamask-mobile-invalid-amount/19663
(https)://community.metamask.io/t/invalid-amount-error-in-the-transaction-i-created-with-web3js-metamask-mobile/19034
(https)://ethereum.stackexchange.com/questions/126327/metamask-mobile-token-transfer-invalid-amount-error

Heya,

What’s the issue that you directly are having, getting the example will help. Example, you have 30 UNI tokens but only 2 are showing up, etc.

Are any of your balances showing in orange?

One last question - did you got to the live help desk agent through metamask.support.io , clicking the blue square “start a conversation” bubble and they redirected you to here?

Thanks!

1 Like

All details are in URL I provided, but okey, I will write the problem here again.

I am using Moralis for simple token transfer from one wallet to another. My code:

And this works great on desktop (Chrome MetaMask plugin):

But when I wanna use this on my phone - iPhone (MetaMask app), I always get error “Invalid amount”, and I don’t understand why, since I am executing same action.

I also tried sending ERC20 directly with ethers.js something like this:
image

Same. Works only on desktop, on mobile I get error “Invalid amount”.

I tried to send MATIC directly with ethers.js, and this is working on both desktop and mobile. My code:

I can send BNB on binance chain no problem, also MATIC on mumbai polygon chain, native works on desktop and mobile. But ERC20 works only on desktop.

Searching for solution I could see that many people have same problem, but there is no solution to this problem.

One last question - did you got to the live help desk agent through metamask.support.io , clicking the blue square “start a conversation” bubble and they redirected you to here?
Yes I did, they redirected me to forum.

2 Likes

Thanks! I’m betting that help desk also put in a ticket for you but I’ll pass this information along too. I appreciate you sending the detail. In addition to the links you provided it’s really helpful to see what you’re experiencing. My apologies, I didn’t realize one of the posts you may have shared was actually your post on a different site; it doesn’t hurt we have it here too! Just provides a more detailed and clearer picture.

2 Likes

Thank you. When can we expect explanation what is going on? We are working on some project and this is kind a core thing that it needs to work. :confused: Don’t know what to do.