Metamask pos bridge does'nt work

when loading pos bridge to metamask instead of going to polygon walletv2 I am take back to sign in!

Hi deadlegs,

If you’re on mobile are you using MetaMask browser in the app?

If on desktop, what browser are you using and has bridge worked prior on the same desktop/browser?


1 Like

KBee desktop and chrome also tried brave and have never got it working

1 Like

When the private key is backed up, you can try to uninstall the metamask plug-in wallet and reload it


done that
do I need an amount in metamask?
do I need to open a wallet in polygon first and if so how

Try disconnecting from the site and connecting your wallet again.

Here is more information on our Knowledge Base:


have tried that dozens of times tried uninstall dozens of times

Can you describe your problem in more detail?

1 Like

when I try to bridge between metamask and polygon it just returns to sign up for metamask instead of going to a polygon wallet I Have MATIC installed on metamask and it says connected wallet polygon technology but fees are still high and no wallet

1 Like

Can you take a screenshot?

Thank you
I go to image 1 i click on poly bridge and
press connect to wallet and i am taken to image 2
I log into metamast
and am taken here image 3 and back to image 2 and go through the process over and over


where is my polygon wallet
do I need to sign up to one

I can’t find any information on whats next

I didn’t see any pictures :face_with_monocle:


In Figure 3, did you click sign?

Yes and it goes back to sign in like refreshes the page
when I Remove metamask and reinstall it with matic and click POS Bridge it asks me to confirm the account then goes back to sign in

Try clearing the cache

Thanks again but have tried several times

Have you ever had the same problem with another computer? Because when we encounter such a difficult and unknown problem, we usually need to make all kinds of attempts to know the problem,In addition, I found that there are many pages in your browser at the same time. I don’t know whether it is related to other pages in the browser connected by metamask. You can close other pages in your browser and try again. This requires patience :wink:


I have tried using a new browser no other windows open, tried to bridge to polygon
same goes back to login
and to be sure I don’t need to make an account at polygon?

If you have made so many attempts and still can’t, you can consider using other cross chain bridges. There are enough cross chain bridges to use, such as iswap and muliti cross chain bridges