MetaMask Registering Contract Methods - Not Working

Hey guys,

I need to register some of my contract methods with MetaMask for my Fantom Smart Contract (chainID: 250).

I have tried the MetaMask docs.

but it sends you to Etherscan, I tried adding my method via the provided register contract and it shows the method is now registered in the test app.

(calls the method correctly via 4byte look up)

But when try to use the methods in my dApp im still getting the ‘contract interaction / unknown method’ .

Is there a FTMScan alternative to register my methods?

Thanks (edited)


Hi @ozftm ,

I’ve passed this message along for a response! Hang tight. :smiley:

1 Like

Hi everyone,

I’ve got the same issue on my Polygon SmartContract’s method that I added to the Mainnet Parity signature registry as the docs suggest.

Here is the method I’ve added if this can help :
0x83451838 => buy(address,string)

And here is the Ethereum transaction to add the method’s name :

I am eager to see if there’s a solution, as this is something important for blockchain newcomers to retrieve as much intel as possible to know what’s happening, in my opinion.

Thanks for your help

1 Like


I was able to find out that for right now MetaMask does not use the Parity on chain registry. So instead you will need to submit signatures here: Ethereum Signature Database

:fox_face:Hope this helps!


Thank you very much for your help, it works !

Maybe this could be added in the MetaMask docs to avoid confusion, if possible

1 Like

Yep, this is in the works :slight_smile: thanks so much for letting us know all is good! :fox_face:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.