Metamask stuck connecting and being undetected by sites

When I click on MetaMask to connect to any site, it keeps being stuck/idle saying “connecting to Ethereum Mainnet”, or it says “unable to connect to Ethereum Mainnet” try again. If I go to for example Opensea and click connect to my account on Opensea, a new window pops up to install MetaMask in my browser. No matter what, It doesn’t detect that MetaMask is already installed in my browser. Because of these things I basically can’t access the MetaMask app. I have tried to restart the computer, and remove and add the MetaMask extension to the browser with no luck. I would like to know what causes it and exactly how I can solve it? without getting further into problems.

1 Like

Don’t you also use some other crypto wallet in browser? For example Phantom wallet?

What if my wallet is not connecting:

10 ways to fix the MetaMask not Connecting to OpenSea error:


No I don’t use another browser wallet. Yes I’ve tried to remove all extension’s from the browser and cleared the cache. Then afterwards only ad the MetaMask extension. When clicking on Openseas connect icon on their website to connect MetaMask, a list with wallet possibilities pop up saying “Connect your wallet”. I of cause chose MetaMask on the list, and a new window then pops up to install MetaMask. In other words it doesn’t detect the MetaMask extension in the browser and ask me to install it. If I click on the MetaMask extension icon in the browser, MetaMask opens and say Welcome back “connecting to Ethereum Mainnet” and then it just stay there idle or says “We cant connect to Ethereum Mainnet” try again. Same thing keeps on going over and over again, no changes.

1 Like

So :thinking: you have problems connecting to the ethereum network. Are you not using any VPN?
Sometimes helps: switch network to Test Network and switch back to Ethereum Mainnet. Test whether there are problems on another browser as well.


Thanks for replying, no Im am not using an VPN. I cant switch to another network because the - Welcome back “connecting to Ethereum Mainnet” and “We cant connect to Ethereum Mainnet” try again MetaMask window, it blocks me from unlocking my MetaMask and switching network. I can and have tried to enter my password several times but other functions are blocked, meaning I cant hit enter or click on the unlock button to enter MetaMask.

That’s wrong :roll_eyes: and do you know your MetaMask seed phrase? Try MetaMask wallet on another browser.

If you don’t know the Secret Recovery Phrase:


Yes, fortunately, I do have. MetaMask was completely stuck and wouldn’t respond to anything whatsoever. However, due to the seed recovery phrase, I did manage to recover my account. I installed MM on another browser cause I don’t trust it running in GC at the moment.


This topic was automatically closed after 30 days. New replies are no longer allowed.