No startpage on mobile browser (default page is null)

When I try to open the MetaMask mobile browser (iOS), the startpage with the bookmarks doesn’t show up anymore. The browser tries to load “null” in the address bar by default. I cannot change the default page it tries to load, and I can’t see or access my bookmarks anymore.

Ofcourse no webpage can’t be loaded if the url is NULL and an error saying " we couldn’t load that page" shows up. I tried removing and reinstalling the app, but the problem remains .

Who knows how to fix this? How can I see my bookmarks again? Or how do I reset the default startpage of the mobile browser?


hi @user2289 , welcome to MetaMask community.

My iOS APP can display pages normally. And after I add bookmarks, they can be displayed normally on the homepage.

Try the following to see if it works

  • Close all pages, kill the APP process, and then restart it
  • Upgrade the APP to the latest version 7.0.1
  • Try to switch your network connection

If that doesn’t work, try going directly to the default home page ( home. MetaMask. io ), and then re-bookmark.


Thanks for your reply. Unfortunately this doesn’t solve my problem. It seems that that URL somehow redirects to NULL for me. I live in the Netherlands. I tried using a VPN and connect through another country and that seems to work.

Could it be that my country is somehow blacklisted from home . MetaMask . io?

Did you just start having this issue with the recent update, or has it been there?

1 Like

It’s been here since a week or two. Worked perfectly before that. So I guess it has something to do with a recent update.

Please reach out to MetaMask Support.

  • This will connect you to a bot at first, answer some questions and it will open a ticket for you with an agent.

Remember - NOBODY, including from support, will ask for your secret recovery phrase or for you to input it onto any website for confirmation.


This topic was automatically closed after 30 days. New replies are no longer allowed.