Pending tx that never hits blockchain, Optimism network

I use Ledger via MetaMask. I’m trying to interact with Optimism and every time I try to do something (use Uni/Sushi, Perp, or just transfer to another address) I will click “Confirm” and then instead of prompting the Ledger it immediately closes the MM extension. I open it back up and there’s a pending transaction, no txid, not on the blockchain, which will sit there for hours (I think 18 hours was longest I waited). The Ledger gets prompts for things like signing BentoBox permission on Sushi and it from what I can tell anything on ETH main net.

List of what I’ve tried:

  1. reset account - this helps to remove pending & queued transactions to start from scratch but fixes nothing
  2. switch between ledger live & WebHID access methods
  3. clear cache/cookies in browser
  4. sign out of MM and sign back in
  5. remove the ledger accounts from MM and re-add them

Probably missing some things but those cover a lot of bases. I was able to bridge into Optimism, claim & delegate OP tokens, all on airdrop date, since delegating tokens everything stopped working.

Here’s the address in question if helpful: 0xB651FCD364aC7462dB24D6a8d9B32C4fD0803915

Thank you.

1 Like

Hi @gumshoe ,

I know this is a basic question but just confirming your ledger is has most up to date firmware version?

Yes, it’s running 2.1.0 and all of the apps on it are updated.

2 Likes

Hello @gumshoe and welcome to MetaMask community.

Have you enabled blind signing on your Ledger device? Just making sure to cover any loopholes on why it may act like you said.

1 Like

Yes forgot to mention that, it’s enabled.

1 Like

Finally figured it out, it was Chrome browser. Something must be conflicting with Chrome & Optimism. I loaded it up in Firefox and everything worked perfectly. Thank you for your comments.

3 Likes

This topic was automatically closed after 30 days. New replies are no longer allowed.