Metamask + Ledger Problem. Confirmation doesn't show on Ledger and transaction fails?

Hello I have problems with Metamask + Ledger. Trying to send from metamask but confirmation message isnt showing on ledger, so transactions fails, any idea how to fix this?

2 Likes

So, after this bridge solution was pushed out only Tron worked. Today not even tron works with the bridge. I’ve tried ledger with chrome (with bridge), firefox, edge, brave ( without bridge), cleared browser cache, cleared system files/cache, logged in out of metamask, turned on/off ledger device, rebooted computer, restarted ledger, restarted browsers, started the bridge with the URL (the bridge starts) metamask just continues to look for the ledger (ledger live program works though). When will this issue be resolved, my ledger is essentially a small brick.

I found a solution
So I finally found a way to get the ledger to work. I used opera and then opera has a google play extension import. I used that to import metamask then connected my ledger. If anyone knows why metamask only works with this solution, let everyone know.

Sounds strange that using Opera worked but no other browser did. I had to enable Contract Data in the settings on my Ledger which seemed to do the trick. I also cleared the “connected sites” (including the one I was on) and disconnected/reconnected the ledger just to start from scratch as well.

Hi guys,

A way to solve this is to create a new metamask wallet in another explorer (NOT IMPORTING YOUR USUAL ACCOUNT) then link your ledger with that new Metamask. Since Metamask is just a door to your Ledger, you will have all accesible again and Ledger signing issue solved. Now you the comunication between Ledger and Metamask is restored.

Hope it helps