Polygon network down?

Polygon network is down on Metamask at the moment?

16 Likes

Not as far as I know, what issues are you having at the moment?

6 Likes

The token balances take so long to load. Anyways, what is the best RPC URL for Matic mainnet network in metamask?

Shall it be polygon-rpc or maticvigil ?

Thanks.

9 Likes

Not sure which is the best one, if there was I would assume it depends on the situation, but here’s a list of different RPC URLs you can try:

5 Likes

I’m having the same error.

Transaction decoding is not available for chainId 137

8 Likes

Hey @dhruvism, welcome to the MetaMask community! :fox_face:

Make sure you correctly configured your wallet for Polygon network, and try using a different RPC URL.

3 Likes

None of the other urls work - Cannot identify chain id

5 Likes

I also tried resetting the wallet, as suggested by somebody on Reddit

4 Likes

Is this showing up for all your transactions, or just one? If it’s just one, it might have to do with the contract you interacted with for the transaction.

3 Likes

Errors in Firebird Finance, Quickswap, Autofarm and Beefy.
I had LP tokens in Firebird, cant withdraw them.

Only zapper seems to work.

3 Likes

Try switching between networks and go back to Polygon, and make sure you are on the latest version of MetaMask. Here is some more information on our Knowledge Base:

Hopefully that helps, if not you can submit a ticket to the support team if you would like:

https://metamask.zendesk.com/hc/en-us and click Start a Conversation

3 Likes

Hey is anyone else see a problem with they’re balances, I logged out last night and everything was fine, today I log in and only my matic balance is correct and all my other tokens are showing 0. I figured slow connection, so I switched from matic network to ETH and back, then matic went to 0. I logged out for a couple of hours and came back…now metamask can’t get in to polygon? Anyone got any info on this?

6 Likes

haven’t checked polyscan, I can’t get on polygon…metamask won’t open matic mainnet, it says OOPs try again.

5 Likes

Thank you for trying to help Luke6 but I’m new here don’t know anyone so i’m not going to put my info on the open forum. Do you have Maticmainnet on your networks? if you do…can you open it or does it tell you oops something went wrong?

2 Likes

ok…yes thanks luke6…i remember that my mcfee did a history and cookie wipe, that might have something to do with it. going to try something brb

1 Like

that didn’t work. how do i find a different URL for maticmainet?

1 Like

lol thank you for time and help luke6…that fixed it …i just copyed and pasted a new tag and everything is working again. thanks and sorry if my noobness caused any headaces.

2 Likes

I’m having a s similar issue with connecting to my polygon network. I can connect to other networks just fine, but I can’t connect to matic and I can’t load my balances on certain Dapps. Has anyone found a solution. I have some loans on mai.finance and need to check the liquidation levels to be sure this drop won’t hurt me

1 Like

Hey @YCB88, welcome to the MetaMask community! :fox_face:

Try adding Polygon as a custom network again :point_down:

If the issue still continues, try using another browser.

1 Like