Metamask can't switch to Polygon network, shows wrong balance and missing tokens on ETH

Metamask was working fine in Chrome until recently but now when I try to switch to the Polygon network it gets stuck on “Connecting to Polygon” for ages before it fails and when I switch to the ETH network it shows about 3x as much ETH as I actually have and none of the other tokens I’ve added and just shows “Loading tokens” forever (and I can’t re-import the tokens because I’ve already imported them so they’re greyed out). The only network that seems to be showing the correct balances is Binance Smart Chain.

This is with my Ledger Nano X account but I’ve got a couple of software accounts and I have the same problem trying to switch to Polygon with those. I don’t really have any balances of anything under those accounts, so I can’t tell if there’s a problem with ETH with those accounts but it seems likely as the Polygon issue is affecting all my accounts, so it’s not a Ledger problem.

1 Like

Hey @rover9875, welcome to the MetaMask community! :fox_face:

Try using a different RPC URL for Polygon, you can find a list here:

If the issue still persists, try these steps written in our Knowledge Base:

Hope this helps :slight_smile:

2 Likes

Hi @nakedwinnie

After not working for about a week, the Polygon problem seems to have fixed itself as it’s switching to that network fine now.

Regarding the problem with it showing the wrong balance for ETH and none of the other tokens, I had already checked that everything was showing correctly on etherscan. I’ve just installed the MetaMask extension in Opera and added my Ledger and it shows everything correctly there, so something’s messed up with the extension in Chrome.

This still isn’t working. Metamask is currently unusable for me in Chrome with Eth because it shows the wrong balance and none of the tokens and some sites don’t work properly with the Opera Metamask, so I really need a fix for this problem.

Have you tried the steps in the article linked above? The same steps apply for Polygon Network

  1. Close down your browser where you have the MetaMask extension installed and open it again.

  2. Switch networks up top by clicking on “Main Ethereum Network”, selecting the Ropsten Test Network, and then switching back to Ethereum mainnet again.

  3. Execute an account reset

  4. Install MetaMask using another supported browser (Firefox, Chrome, Brave) from our official website https://metamask.io , and then try restoring your wallet using the 12 words Seed Phrase / Secret Recovery Phrase in case the issue is only present in the browser you are currently using.

1 Like

As I said previously, it works fine in Opera and I’ve already tried closing Chrome and switching networks several times, so the only thing I haven’t tried is an account reset. I’m a bit nervous about doing that because of reports that the additional accounts go missing after restoring but I guess I should be OK as I’ve already got it working in Opera so it won’t really matter if the accounts don’t show up in Chrome.