Swiching network show only ETH

My problem is when i open my MetaMask on Eth network when i swich my network to bnb , polygon , … every network my token show ETh for example i have 10 matic show 10 eth , in bnb network have 10 bnb show 10 eth every neetwork i swich show eth and dont show real token !

3 Likes

Hello and Welcome to MetaMask community,
I encountered a similar issue, and I asked it from the community and I was told that the loading delay has caused it. Please refer to this post: The FTM value on Fantom network was shown as BNB
I encountered a similar issue several times since my last post and as it took over 1 hour for MetaMask to “display” the tokens correctly, therefore, I am not sure that the problem is due to the loading delay.
Despite this fact, since MetaMask considers the correct value when doing transactions under that condition, I did not follow it up again.

3 Likes

No its not because after 1 2 3 hour nothing change !

hello,@Saeedrp
The reason for the loading delay, I also have a short error when I switch networks, if you are very worried that the funds will be wrong, you can try to close the browser and reopen your wallet to check whether the display is wrong , or view through the chain

3 Likes

For my case it took over hours as well.

1 Like

Hello @998755 Sometimes a similar issue takes hours to get resolved. Therefore, I am not sure that it is due to the loading delay. I have closed and opened MetaMask, closed and opened the browser … and again the same issue. It got resolved after hours, but I have no idea what caused such an issue and how it got resolved.

3 Likes

Hello @Saeedrp, welcome to MetaMask community!

In addition to everything Maryam1 and 998755 answered, i would suggest to also try to remove one of the networks, with the least amount of custom added tokens (so it won’t be a problem for you to re-add all of them), and then re-add the network.

1 Like

In fact, this problem can be easily solved. You only need to continue switching between the ETH chain and other chains for many times to display normal.

5 Likes

Hey @Saeedrp ,

Can you try clearing your cache/cookies?

Also, what version of MetaMask are you running and on what browser do you run it?

Any other wallets on same browser?

Thanks!

Thank you man. My problem is already solved

This topic was automatically closed after 29 days. New replies are no longer allowed.