Matic mainnet cannot be connected to Metamask

Hey guys, anyone having problem connecting to Matic Mainnet through metamask browser extension just like me?

Is it related to the attack on Polygon network recently, causing the price crash of TITAN?

1 Like

Also seeing this same behavior on Firefox using Metmask.

It looks like it’s trying to connect, but eventually fails and says “Oops! Something went wrong.”

Another user, @Stephonmetamask is reporting this – however I can’t add links to this post. Search for “Unable to connect to matic network”

Well I restarted my PC and the problem solved .

发自我的iPhone

Hello i encountered an issue, since today, my metamask on chrome is not able to connect to the matic mainet.

i have the message “connecting to matic mainnet” until it “oops, something wrong…”

It is working from my mobile phone.
Any clue ?

Try restarting your PC

发自我的iPhone

Thanks @Marcus-21 – tried that but didn’t seem to work. Still hanging when switching to the Matic network. I’m on MacOS, 11.4.

Please to removing the RPC network and re-adding them back.
Polygon
Network URL
https://rpc-mainnet.matic.network
Chain ID
137
Currency Symbol
MATIC

Sorry , I am on Windows.

发自我的iPhone

Try “math wallet”. I use it on my iPad to access matic mainnet and it works fine.

发自我的iPhone

Hi @lsq I refreshed this in Metamask and I’m receiving an error: “Could not fetch chain ID. Is your RPC URL correct?”
I cannot attach an image at this time as permissions on the forum will not allow it for a new user.

Confirming I’m using the same RPC URL you listed here, and Chain ID: 137.

@Marcus-21 @Stephonmetamask I found a solution that worked for me. I switched the RPC URL.
It’s restricting me from listing a URL here so I’ll try this:
https
://
rpc-mainnet [DOT] maticvigil [DOT] com
Or try a search for “matic network Ethereum Mainnet rpc” and you’ll see the MATIC documentation which contains a few URLs to try.

Thanks a lot guys

发自我的iPhone