Metamask is stuck on "Connecting to Ethereum Mainnet"

Been using MetaMask in Chrome for 2 years without issue. Today I ran into an issue where it would get stuck connecting to Ethereum. Eventually it would time out and would allow me to select another network. I could select another network and it would work. When I went to change back to Ethereum issue would re-occur.

I uninstalled the Chrom plugin and re-installed but issue remained. I then tried to use Edge and Firefox but same issue in all browsers. I even created a new windows profile then installed MetaMask but I got the same issue. It tries to connect to Ethereum even before it allowed me to restore wallet via secret key.

UPDATE - I installed MetaMask in Chrome on a spare computer and also got the same problem so issue is not computer specific…

Running Windows 10, latest version on all browers. Enabled dev mode in MetaMask and ensured its also latest version.

Any ideas on how I can get a clean install of MetaMask so I can restore my wallet via secret key?


1 Like

Hello @ant75a, welcome to the MetaMask community,

The issue is likely related to the Ethereum RPC. Change the Ethereum RPC from the following link. Please remove the 2 spaces I inserted in the link.
https:// chainlist .org/
Click on the small arrow at the bottom of the Ethereum network box and add an appropriate RPC to your wallet.

The following article is related as well.


This topic was automatically closed after 30 days. New replies are no longer allowed.