Ripple sent to Matic address

Hi guys,

A couple of weeks ago, a friend of mine tried to send his RIPPLE token from his Binance account to Bitavo account. Unfortunately he was distracted and send his RIPPLE accidentally to a MATIC wallet address using BEP20 as transfer network.

Binance suggested to get in touch with Metamask support service to which they replied with a generic email that has nothing to do with the problem and case was closed. He can’t get his token back so he contacted me as a last resort. I tried several solutions, but none of them worked out. Any advice you could give would be much appreciated.

Transaction hash: 0xabfc953035c6486cc5eb03846aa318f9737e80606b975225a4e212f99fbfa2eb

1 Like

Hey @xHeartlessx, welcome to the MetaMask community! :fox_face:

Thanks for looking out for your friend :fist:

Was the wallet address he sent the RIPPLE to a MetaMask wallet? If so, he can add BSC as a custom network and the RIPPLE should show up.

Here is some more information on our Knowledge Base:


From my understanding it is sent to his MATIC wallet address on Bitvavo. Bitvavo couldn’t do anything, because they didn’t receive it. Binance also couldn’t do anything, because they don’t have the tokens anymore. Binance asked me to set up Metamask and add Binance Smart Chain network. After the setup they told me to contact Metamask support.

If I had to guess, you need the wallet’s private key to send RIPPLE back.

1 Like

Unfortunately, since the tokens were sent through the wrong network there is nothing that can be done, especially since both Bitvavo and Binance said they can’t do anything. All transactions on the blockchain are irreversible.

Not sure why Binance told you to contact MetaMask, there was nothing involving MetaMask in this transaction lol :laughing:


I don’t know either :sweat_smile:. I’m just the messenger :laughing:. This time I will contact them myself. Wish me luck.

1 Like

I carefully read the messages between Binance and my friend. Metamask has indeed nothing to do with the transaction (I should have known better). Only Bitvavo can solve this problem, but they will not help him. The unsupported tokens (RIPPLE) are in MATIC Bitvavo address, so it entered the Bitvavo network.

This is what I found on Bitvavo’s webiste

1 Like