RPC error message

Referring to attached error message.

I would appreciate your support after searching the forum thoroughly as I couldn’t find any answers to this.

I was simply trying to cancel a pending low gas transaction by sending a 0 ETH transaction with the same nonce to my own address. I constantly receive the error as per the attached. The only answer I found to this in the forum was to increase gas for my 0 ETH transaction but this wouldn’t help in my case either.

What could possibly solve this?

1 Like

Hey @flob, welcome to the MetaMask community! :fox_face:

What is meant by increasing gas is to edit the gas fees in gwei to a higher amount, while still keeping the ETH amount to 0.

Here is more information on our Knowledge Base:

Thanks for taking the time to answer but that’s clear to me. I’ve even checked current gas levels and went way beyond it. It did give me the exact same error message.

Do you currently have enough ETH in your wallet to cover the gas fees for the transaction?

If yes, try resetting your wallet and trying again :point_down:

Yes, I have more than enough ETH and I’ve done several resets already. Anything else that can be tried?

Im having the exact same issue! - Tried all the usual tricks to clear, i have now reset the account and my transactions still will not go through, there are no “stuck” transaction on the wallet. Its very frustrating. Anyone have any tips?

Have you tried working from smartphone MM app? i managed to send eth to myself and it completed. Once gas comes down a bit i will try to buy and see if it works from iMac and then update

1 Like

Sorry to hear the issue still continues :frowning:

As @nft_kidz suggested, you can try a different device or browser.

Thanks but in my case not feasible as it’s connected to a hardware wallet

This topic was automatically closed after 30 days. New replies are no longer allowed.