Security phrase invalid after re-installation

When I tried to open my Metamask app on my Iphone noticed that I’ve been logged out.
When I tried to log in using my password, I got a red error message saying that I had to
reinstall Metamask app.

After reinstalling the app I tried to import my account using my Secret Recovery Phrase.

I’m sure that I have written the correct words in the right order. But I get an error message saying “Secret Recovery Phrase is invalid” when I click the import button.

Is it that I’ve been hacked and the hacker has changed my security phrase? Or is this something that can be solved?

Please I really need help to recover my account!

I’ve created a new account and tried to change the security phrase, but I couldn’t find that option. So it seems unlikley that my security phrase has got changed.
What could have happened? It’s like my whole wallet has disappeared.

Please help!

Edit 2:
The security phrase is the correct one, since I remember trying it when I first opened the wallet.
The whole wallet seems to be missing.

At the ‘Import account’ page there’s a text saying " imoprted accounts are viewable in your wallet bit are not recoverable with your Metamask security phrase.

when trying to import the wallet adress to my new one it cannot access.
I have my security phrase that doesn’t work.

113 tbone tokens and 45m xShib tokens have I lost if it can’t be solved.
I really need help to fix this…

Edit 3: Correcting what I wrote in edit 2. I don’t have acess to my old account. The adress that i remembered as mine didn’t work, ande the one I could connet to was in fact txid from an erlier transaction.

Hello. When check etherscan those your tokens still show or you see zero ?

Thanks for the answer. I saw I’ve written wrong in my text in my edit2. In fact it was an txid from an erlier transaction that I could connect to. My account number didn’t work.

Problem solved. One letter wrong in phrase.