Snap is asking for version 11 update

Help!! Having issue connecting snap, MetaMask is already updated
Ussing Brave
Tried restarting the browser but no luck.
Tried updating meta on developer mode but no luck.

hey @swagcat . Back up your seed phrase and reinstall MetaMask. See if it works.

Someone solved the same problem using this method.

1 Like

Thank you will try that, Just wondering. So i got 4 accounts on meta mask. Is all 4 going to get recovered as its shows same seed phrase for all 4 accounts.

yes. all accounts with the same seed phrase will be restored.
So, be sure to keep your seed phrase safe :cat:


All accounts were not restored and its still not working.

Please reach out to MetaMask Support.

  • Visit :

  • Click the large blue “start a conversation” bubble in the upper middle of page, looks like this:

  • This will connect you to a bot at first, answer some questions and it will open a ticket for you with an agent.

Remember - NOBODY, including from support, will ask for your secret recovery phrase or for you to input it onto any website for confirmation.