Can't update Metamask (even manually)

My Chrome MetaMask version is 9.x.x and even when I manually try to update MetaMask in developer mode, it says that MetaMask has already been updated to the latest version, but the version remains 9.x.x. Could you please tell me how is it possible and what should I do to get latest version?

hi @bebop ,welcome to MetaMask community.
Normally, restarting the browser will update the extension to the latest version. Have you tried doing this?

1 Like

Hi! I’ve tried to restart browser and update manually, nothing works. My MM extension has “Unpacked extension” sign (I don’t know why). Could it be that it is impossible to update unpacked extension?

Hi @bebop, welcome to MetaMask community!

What is your Chrome browser version?
Before doing any other moves, make sure you backed up your Secret Recovery Phrase somewhere safe, offline, and don’t share it with anyone ever.

Have you tried reinstalling both browser and MetaMask extension? There might be processes on your PC also, blocking it from updating altogether. But first make sure to do what i wrote above.

1 Like

I have latest browser version. Is it any way to contact the MetaMask team?

You can contact Support at by click Start a Conversation button and going through the initial bot interaction.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.