Transaction Error code -32602

Hello,

I am receiving the below error for every transaction I attempt, including swaps, claiming rewards and sending eth to another wallet.

Unknown error: "Error: [ethjs-query] while formatting outputs from RPC ‘{“value”:{“code”:-32602,“message”:“transaction could not be decoded: unsigned transactions not supported”}}’

I am wondering if anyone is familiar with this error and has a solution.

Thanks for the help

5 Likes

Same issue too:

Error: [ethjs-query] while formatting outputs from RPC ‘{“value”:{“code”:-32602,“message”:“transaction could not be decoded: unsigned transactions not supported”}}’

I’ve even tried high gas fees to no avail. First got it when I tried to send and convert SPL USDT from sollet to ERC20 to my metamask wallet. I can’t make any transaction with metamask now. Tried resetting it to no avail. It’s the metamask that comes with Brave browser. I’m using latest version of browser and macos. More than a day now. Baffling!

1 Like

You are a scammer. Where are the mods to boot the poster off this platform?

I found the below. It didnt work for me but I thought I would share it in case it can help you:

Fixed by changing the Chain Id of your localhost network in metamask.
The default is 1337, but hardhat is configured with 31337.
If you open the console you’ll see the whole error message and the last bit says that there was an error singing the message with the wrong chain id.

Metamask => Circular icon button => Settings => Networks (scrolldown) => Find Localhost and change the chain id to 31337

Best of luck figuring this garbage out

When I go to update that ID the field is greyed out — at least for the Eth network (because that’s the default that gets created automatically?) So how would you go about changing the chain ID from there?

How can this affect some people but not others? I’m also unable to transact

So…just figured out you weren’t talking about the Eth Network, but for me the Localhost 8545 network does not let me update the chain ID field (currently showing blank but also greyed out

Likewise. Chainid is blank and does not accept any value

Mine just got fixed by itself. Have you retried your transaction? I was even able to make another transaction on xdai chain via metamask.

1 Like

Thanks for the heads up. Mine seems to have resolved itself too!

1 Like