ERROR: Transaction decoding is not available for chainId 42161

Hi, I’m trying to claim Arbitrum Airdrop from my ledger and I always receive this error:
Transaction decoding is not available for chainId 42161

I have enought eth for gas, because I claimed the airdrop from another account with the same amount of eth($100) and worked fine.

[ethjs-query] while formatting outputs from RPC ‘{“value”:{“code”:-32603,“data”:{“code”:-32000,“message”:“max fee per gas less than block base fee: address 0x42C14FBbB183f796be06F6EE5faB5181e9c6024a, maxFeePerGas: 6614352000 baseFee: 12015270000”}}}’


Hi friend! @rrigo I believe you have to set the gas price up manually and then you might get the transaction through. Currently a lot of people are claiming though so your transaction could fail.

Best regards


Hi mate,
I tried earlier increasing the fees without success, but now I could claim whithout any changes.
I think MetaMask could saw this information from the network and auto increase and decrease the fees.

1 Like

Did you find a solution? Cant make any transactions on arbitrum using my ledger.


I did nothing, but I have the same behavior.
I tried to send some funds without success and came here to find some answers.
MM is giving a lot of strange errors.


I received my ARB tokens and am trying to send ARB tokens from MetaMask (on Arbitrum One chain) to my binance ARB wallet:
0x8897e2a9005dd3fdcd2a472dd55ffdcf85984ea7 (on Arbitrum One chain)

But I too get an error : “Transaction decoding is not available for chainId 42161”

1 Like

The problem has been solved. I had interchanged the RPC URL for ARB one chain with ARB mainnet


The Arbitrum Network API was been facing some delays recently due to the airdrop.

This should be resolved now :slight_smile: .

1 Like

I’m trying to unstake some Arbpad tokens on Arbitrum and when I withdraw, MetaMask how 2 warnings…(1) “Transaction decoding is not available for chainId 42161” and (2) "it says I don’t have enough ETH b/c the cost is like $5M USD. I’m scared to proceed with the transaction b/c of these two red warnings. Based on my research, it sounds like I have the wrong chain but everywhere I read, chainId 42161 is correct for Arbitrum. I assume once I get the correct chainId, the fee will change to a reasonable amount. Please help. I need to unstake these tokens.

@user1215 Hello!
Welcome to MetaMask community )

Just try do it :smiling_face:


This topic was automatically closed after 30 days. New replies are no longer allowed.