Transaction decoding is not available for chainId 43114, Metamask doesn't support Avalanche network?

For 4 days i’m having this issue, i can’t buy any nft or tokens in Avalanche Network with MetaMask extension. I tried everything, re-install chrome and MetaMask, cleaning cache and cookies. But still there is no solution. When i try to make a transaction in Avalanche Network i’m having this error:

Transaction decoding is not available for chainId 43114.

I missed a lot of promising mints, and looks like i’m going to miss more. Please share a solution with me.

I’m using MetaMask Chrome Extension in Windows. Thanks for replying

3 Likes

Hey @Meco, sorry to hear this is happening.

Do you have AVAX set as the Currency Symbol in your custom network settings? Do you have enough AVAX in your wallet to pay for the gas fees?

3 Likes

Thanks for reply, yes it’s AVAX. Also i try to add network manually and from chainlist but results are same. And about gas i face with very absurd gas fees for Avalanche Network but i tried to pay that gas too but transaction failed. I searched and i saw many people having this problem, i think it’s about metamask extension. But i re-installed chrome and metamask for many times. I checked the all i’m not an expert but it might be about software of metamask extension. Hope you help and guide me about this problem cuz i’m planning to invest many project in AVAX and this problem is very upsetting.

4 Likes

I don’t know what you’re talking about. Upgrading metamask to layer2 with using helium blockchain? This doesn’t look like a solution. I’m sure i use the last version of metamask

3 Likes

Is this issue only happening for you on extension? Have you tried it on mobile?

Have you also tried adjusting the gas settings for a higher amount? Here is more information on our Knowledge Base:

2 Likes

The problem is not about gas, i’ve never see 2 AVAX for gas fee anywhere. It seems a software problem or sth, also says “Market buy order with ETH” as transaction name in Metamask approve screen.

And yes i tried in mobile couple times fees etc everything was ordinary but transaction failed. You can check the transaction in snowtrace, this is txhash: 0x0129cb11ac50f068051c519921a60106c80a43629a2c6e78947cc2028f2efcfb

3 Likes

It is asking you for 2 AVAX? :dizzy_face:

Would you be able to send a screenshot? That would provide more helpful information.

What happens when you manually lower the gas?

3 Likes

I lower the gwei to 1 but anything changed. I sent back my tokens from wallet but here there are some screenshots fees are like 0.5 or 0.05 avax which this is too much for avalanche network. And i even try to pay these fees and buy but ofcs transaction failed.

01avax

6 Likes

Sorry to hear this is happening and the problem continues :frowning:

If you would like, you can submit a ticket to our support team at https://metamask.zendesk.com/hc/en-us and click Start a conversation

2 Likes

Hi, I am having the same exact problem but on oasis network. did you manage to solve this problem? Its defently not a gas problem

2 Likes