Set Avax from Coinbase to Metamask and it keeps showing as ETH

Hi,I sent Avax from coinbase and it keeps showing as ETH on top of the WAVAX and AVAX symbols under the Avalanche network, I set it up correctly with c chain etc. but don’t know what else to do and why it keeps saying Its ETH. I Wanted to try and stake time on wonderland but Avalanche support says I have no AVAX for gas when he looked but yet I sent Avax from Coinbase…It gave me an RPC error code when I tried sending my time to Wonderland to stake to from Metamask. I’ve been doing research for a month now and cant figure this out…any help would be greatly appreciated=)

Hey @Khart48, welcome to the MetaMask community! :fox_face:

Make sure you have inputted AVAX as the Currency Symbol when adding a custom network.

1 Like

yes I did all of that exactly as it stated,

Would you be able to send your wallet address? That would provide more helpful information.

You can also try doing a reset of your wallet. Here is more information on our Knowledge Base:

1 Like

Hi Winnie,my address is

Thanks for your help!:blush:

It does look like AVAX is correctly in your wallet on Avalanche network.

Would you be able to send a screenshot of your network settings for Avalanche?

Localhost 8545
Avalanche Network
Smart Chain
Network Name
Avalanche Network
https ://
Chain ID
Currency Symbol(Optional)
Block Explorer URL(Optional)

Make sure that you have the optional fields filled out.

AVAX for Currency Symbol and for Block Explorer URL.

1 Like

I tried to add it but it wont let me

From the looks of the screenshot you sent, your MetaMask UI looks a little buggy. Try restarting your browser or using another browser.

What happens when you try to add AVAX under the Currency Symbol? Can you send a screenshot of the error?

1 Like

I tried to do a regular screen shot of it and it said it couldn’t do that for some extensions but it looks “Normal” just has ETH on top of AVAX and WAVAX.I click send AVAX from Coinbase and use my mainet avalanche wallet address and thats what it does.It sends the AVAX to the top of the AVAX logo and it says ETH.

Yes, the issue is that AVAX is not added as the Currency Symbol. Please refer to this article on our Knowledge Base to reach the page to set up a custom network, and add AVAX as the Currency Symbol for Avalanche network.

1 Like

Hi,here’s the pic I took showing Avax is allready added as a currency symbol.

PS, When I try to add the currency symbol and the block Explorer URL it just erases as I type it in…

I see, not sure why it is deleting it like that.

If you would like, you can submit a ticket to our support team by going to and click Start a Conversation

Hi,no response from my ticket I sent…how could it be showing AVAX on my avalanche mainet if I didn’t add it previously? Please see pic above…ty=)

AVAX is the default token for the Avalanche network, so it will show automatically. Similar to how ETH shows automatically for the Ethereum network.

The support team will be with you as soon as they can, thank you for your patience! :slight_smile: