Unable to connect MetaMask extension to Web3 site

I have problem connecting to my METAMASK wallet (extention in Chrome / brave). I just get this spinning wheel. I have tried both Chrome and Brave and interacted with different defi-sites. Uniswap / 1-inch / pancakeswap. The same result unfortunately, it seems to be 4 tasks pending if looking on the icon, but METAMASK is stuck… Please advice.!



@robfor48 Welcome to the MetaMask Community!! :fox_face: :rocket:

Thank you for providing the screenshot. Here are a few things to try:

  • Connect your wallet on the landing page of Uniswap, Pancakeswap, etc. before going to the swap page and entering in a swap.
  • “Lock” your MetaMask wallet and log back in.
  • Clear your web browser cache and try again.

Let us know if you continue to have trouble.


I’m having a similar issue. I can’t connect to any sites. All MM does is spins like it’s loading. The icon on Brave shows the number ‘6’ so I assume that there are some transactions that are stuck. There is nothing I seem to be able to do to approve or cancel since all I get is the spinner. How do I clear those out?

1 Like

I have this too, created a ticket on the old (obsolete) support site [#110658]

First encountered this with Pancakeswap/Chrome/MacOS. Tried recovery on Linux/FIrefox, works ok, play a while with Pancakeswap, have forever spinning wheel on the Firefox/Linux combo as well. oh well. clearly this is reproducible, quite easily even. Browser restart does not help.


Seems that the lighter options do not work, and that recovery from phrase is the only way to recover [sic] from this situation. Good that there is a way, but having to resort to the recovery phrase is unacceptable imo.


@methyl Glad to hear you were able to resolve this issue with uninstalling and reinstalling MetaMask and restoring your wallet. Remember to securely save and store your secret seed phrase before doing so. NEVER give it to anyone for any reason. We will ever ask for it.

@stoic & @robfor48 Can you please provide the device, OS, and version of the MetaMask extension you are using?

1 Like

I’m in MacOS (Big Sur) using the chrome extension version 9.2.0 on the Brave Browser. it is currently stuck on another transaction on the Binance Smart Chain. I was just trying to approve being able to stake some crypto.

1 Like

@stoic & @robfor48 Thank you for your patience as we worked to resolve this issue.

We’ve released an extension update that will resolve this. Please update your extension and try again. Let us know if that issue persists.


I can see there is an update. What I don’t see is any way to upgrade/update. How do I go about this without having to remove and reinstall?

I figured it out. I’m in Brave, so I had to choose Developer Mode, then the Update button showed up.

I have the same issue - cannot get MetaMask to connect to Pancakeswap or any Web3 Site. I have tried connecting wallet to landing page, “lock” MetaMask and log back in, clearing web browser cache, reinstalling MetaMask completely… nothing is working.

I’m using MacBook Pro (Retina) OS X El Capitan Version 10.11.6, MetaMask Version 10.1.0, Brave Browser Version 1.29.81 Chromium: 93.0.4577.82

Please help…

Hi there.
What are the steps you’re using to connect to the web3 sites and what are the result behaviors?

When I go to PancakeSwap main page and click on connect wallet, the pop-up appears to select the wallet you want to connect to, when I select MetaMask nothing happens - this has been happening for over a month now, it used to work fine previously… Similarly, when I am on BscScan in the “write contract” tab and I click on “Connect to Web3”, the “connect a wallet” window pops up and when I select MetaMask nothing happens.

Have you had a chance to check it against this article? https://metamask.zendesk.com/hc/en-us/articles/360038596792-Using-MetaMask-wallet-in-Brave-browser