Uniswap wont connect

metamask wont connect to uniswap, give repetitive error, or states use correct network even while metamask set to the main ethernet networkj,
any thoughts

Are you connecting on the mobile or browser extension?
Have you had a chance to switch networks a few times?
Besides the message asking to user correct network what other error messages are you getting?

Browser from chrome
Tried multiple times
Updated chrome browser nothing
Switched to Firefox and no problem

hi Manzden, is this sorted? I have a similar error

Nope
Switched to Firefox works on that browswer

1 Like

For connections on Chrome, we haven’t been able to replicate the same issue.
What kind of error messages do you guys get?

I am trying to swap CHAIN for ETH. Uniswap asks for permission to access the CHAIN in my MetaMask wallet. When I hit Approve noting happens.

Hi there!

A few questions for you for troubleshooting:

  • Are you on the mobile app or web browser extension?
  • What device and OS?
  • Can you confirm that you are using the latest version of MetaMask and your OS?
  • Are you using a hardware wallet?
1 Like

Same problem here guys. Ever since I connected to BSC network for a few hours, Uniswap won’t connect anymore (even though I obviously connected back to Ethereum Mainnet from within Metamask).

Error I got at first on Uniswap was something like “wrong network”. Now it just says “error connecting”.

I’m using Chrome. Have tried both through MM through the browser and the Chrome browser extension. Same issue. Again, I’ve connected back to Ethereum Mainnet inside Metamask. Is there something really obvious I’m missing here?

Any help appreciated.

Hi, @MaxJ Welcome to the Metamask Community. Have you tried togging the networks a few times?

Hello I am having the same problem on iphone with the app, I just set up BSC and swapped back to Ethereum network and now will not connect to Uniswap giving me error that I need to connect to correct network.

Thank you

try toggling the network a new times than back to eth main net for Uniswap