WETH didn't appear on account

Dear all,
Next year I’m getting 58, so I’m not into technology. Please help.

I’ve exchanged Polygon to WETH via sushiswap, but it did not appear on my WETH Metamask account.
From address: 0xcb2de6d7cc49fb34a1f9280c1f97e6b9f09922c5

To: 0x1b02da8cb0d097eb8d57a175b88c7d8b47997506

Tx hash: 0xd32477603424d46e9bdd0e9192ce482a1e62009fcde181caa6d6473f141b4652

There was a message on Metamask **Firefox app(**which I use on my computer): Unable to load balance.
My app is updated and reinstalled, but still no result.

I’ve researched the whole forum and nobody has found any solution for this. What can I do?

Hey @JanGa, welcome to the MetaMask community! :fox_face:

It’s new technology for all of us, so we’re all learning together :slight_smile:

Please make sure you have imported WETH on Polygon as a custom token. Here is more information on our Knowledge Base:

Contract address for WETH on Polygon:

1 Like

Yes, I’ve tried also it, but no result

It looks like you are on Ethereum network, but your WETH is on the Polygon network.

Please make sure you have added Polygon as a custom network :point_down:

oh yes, thank you so much! Found it!
Do you know, if I can use this WETH on Polygon network for Opensea NFT?

1 Like

Glad it worked :slight_smile:

If the NFT is available on OpenSea on Polygon, then you will be able to buy it with WETH.

This topic was automatically closed after 30 days. New replies are no longer allowed.