Why does my wallet still show my assets after successfully transferring them all out?

I have looked through all the similar posts I could find, to no avail.

The problem: I transferred ALL my assets from my MetaMask wallet to my cold storage wallet about a week ago. All transfers, just 2 of them, were successful and I can confirm this on etherscan. However, I still see all the same assets in my MetaMask wallet. I want to delete my wallet, but I need to be sure it’s empty first. I clear cache and turn off my computer every night so it gets restarted every day. Still the same problem when I open my MetaMask wallet.

Please advise.

1 Like

hi @Diggerlou ,welcome to MetaMask community.

The most accurate way to check the token balance is to use the blockchain explorer, just judge by its results.

To solve your problem, have you tried switching to a different network and back again?
Here is a related article.


This topic was automatically closed after 30 days. New replies are no longer allowed.