Account will not import wallet, 'Import' is greyed out

Hello,
I am new to Meta Mask. I am trying to connect to my MyEtherWallet, but when I choose Import Wallet, enter the phrase, create the new pword, and check the terms box, ‘Import’ is greyed out and it will not let me import the wallet.
Has anyone encountered this?

Welcome to the MetaMask Community @DiannaS21!! :fox_face: :rocket:

Please try the steps found our Knowledge Base article about using MetaMask & My Ether Wallet.

If you have any further questions, please let us know.

Hello,

Thank you for sending the link but it does not help me with the issue I am having.
I would really appreciate being able to talk to a person. It takes sooooooo long to try to do this back and forth through emails.

As I previously explained, the issue I am experiencing is as follows:

I have set up a wallet in MyEtherWallet and added ETH to that wallet (Let’s call it Wallet #1). When I tried to connect to that wallet in MetaMask, it would not connect.
I tried the process again from the beginning thinking I did something wrong. In trying it again, when I got to the part where I try to connect to MetaMask, it Still would not connect so I chose create a new wallet (Wallet #2). That is where things went wrong.

Metamask is now stuck on that second wallet, Wallet #2, that I created when trying to connect to MetaMask.

The problem is, I cannot connect MyEtherWallet to Wallet#2. I have tried so many times to connect to Wallet#2, delete Wallet#2… I’ve searched blog posts for hours. Nothing.
AND, I cannot get Metamask to connect to my real wallet, wallet#1 in MyEtherwallet.

SO… I have no way to use MetaMask because it is stuck on a wallet I cannot fund AND I have no way to use the ETH I do have in MyEtrherWallet because MetaMask will not connect to it.

So, PLEASE… call me and help me delete this second wallet, Wallet#2, that was created when I tried to connect to MetaMask and help me connect MetaMask to my real wallet in MyEtherwallet that does have some ETH in it.

This issue has been preventing me from buying anything for a week and a half now.
PLEASE contact me and help me with this issue.

Sending links to random articles is not helpful.

Kind regards,
Dianna

Thank you for clarifying your issue.

For your privacy and security, NEVER post your phone number on a public forum.

When importing your wallet to MetaMask, you will need the private key, not the seed phrase. You can find steps to import a private key here.

Before doing this, securely save and store your MetaMask wallet’s seed phrase (NEVER give it to anyone for any reason).

Uninstall then reinstall your MetaMask wallet. Next, import your privacy key as outlined in the link provided above.

Please let me know if you have any further questions.

1 Like

Hi Beth,

Thank you for the information.
I never set up a private key with the wallet that MetaMask is stuck on.

Kind regards,
Dianna

Hi Dianna you write:

I have set up a wallet in MyEtherWallet and added ETH to that wallet (Let’s call it Wallet #1)

You have some words from web page myetherwallet? (12 - 24 words, your secret SEED)

Hi,

Yes, I do.

Dianna

OK Dianna this guide is not for beginners :exclamation: be careful

Open this page: How to extract private keys from other wallets : Coinomi Support
and download file :point_right: bip39-standalone.html FOR SAFETY turn off your
internet connection :bangbang: and open this html file in your browser.

For next steps :point_down: see this picture

Seed generated your ETH privat key :slightly_smiling_face: SAVE and HIDE this key
Import your privat key to Metamask wallet :point_right: How to import an Account

1 Like