"Import a Wallet" Button does not do anything

Metamask stopped accepting my password today. When I try to restore my wallet using my seed phrase, the blue “Import” Button does not seem to work. When I click it, the form flashes briefly but nothing happens. The button is not greyed out. The seed phrase is recognized as correct.

I uninstalled and reinstalled the browser extension on both Chrome (Version 99.0.4844.84) and Firefox (Version 99.0) on a Windows 10 system but the result remains the same.

Any pointers?

2 Likes

I’m having the same issue. I tried on two different computers. I downloaded the chrome extension, and selected Import Wallet with Secret Recovery Phrase. I enter my correct 12-word phrase, create a new password as instructed, accept terms and conditions, and then hit the “Import” button. Nothing happens. It doesn’t give me an error, it just doesn’t do anything.

3 Likes

You can check the link I sent above

1 Like

Thanks for the response, but this isn’t making sense to me. When I download the Chrome extension, there are only two options on the landing page. Option 1: Import walled with secret recovery phrase. Option 2: Create a new wallet. There is no option to import a wallet with the private key.

2 Likes

Thanks for the response. I don’t see how importing via private key would be possible at that point. The only options are to create a new wallet or recover via seed phrase.

Having said that, I got the button to work by typing my seed phrase into a notepad window with the words delimited by line break and pasting it into the text box for the first seed word. Seems counter-intuitive as the seed phrase was accepted before (button turned from grey to blue) but this helped.

2 Likes

What version of the extension are you running? Might need to force an update. (circle icon, settings, about)

  1. Open your Chrome browser and right click on the Metamask logo in the toolbar.
  2. Select Manage extensions.
  3. Extension page opens in your browser.
  4. In the extension page, toggle on the Developer mode feature.
  5. Click the Update button.
2 Likes

Thank you for sharing this! This tactic worked for me too. I typed out the recovery phrase in a different document, copied and pasted into the first field and it was accepted.

2 Likes

This topic was automatically closed after 30 days. New replies are no longer allowed.