Import Wallet > IMPORT button not working?

Several days ago, an error message popped up

“This extension may have been corrupted”

and there was a “Repair” button in the same message, I pressed but it did not seem to solve anything. I then uninstall and reinstall the extension and there were two options:

Import Wallet / Create Wallet

Pressed Import Wallet and entered the 12 word seed phrases correctly, T&C field clicked & Password set

Then the IMPORT button turned blue, when pressed the only response was a brief loading icon flashed for millisecond in the centre of the recovery page.

Tried uninstalling and reinstalling extension and repeating the above process multiple times, problem still persists.

Does anyone had / have the same problem here? Its really frustrating…

1 Like

Have you tried in another browser ? That would be the next thing I would try to see if it could fix it.

3 Likes

hi JKO -

Welcome to the MetaMask Community :fox_face:

I always get nervous if something asks for my seed phrase in a situation like this.

Have you tried connecting with the MetaMask help desk live support team? In the upper right hand corner of the screen you’re on, you can click “Knowledge Base”, if you scroll just a little bit down on that page you will see three big blue square buttons, one that says “start a conversation” it looks like below -

image

Click that, it will initially connect you with a bot but once you answer a few questions it will get you to a live agent.

One question, which piggybacks on @BlueSpaceBike 's note, have you tried using Chrome? Sometimes if it’s browser related that’s the best start. However, we want to know what issues you’re having with the browser you’re on too!

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.