ADA to ETH Swap Missing Funds, please help

Hi everyone! New here, but not new to crypto.

The other day I tried to Swap my ADA to ETH. I was on the BSC Network. It says the transaction was a success. But my funds are nowhere. I thought it would auto put the funds in my ETH mainnet wallet. But it didn’t. And the Address it says it sent them too, is not in any of my accounts. I tried to add ETH as a token on the BSC network. But it still doesn’t show.

Are they funds lost? How do I recover them?

I reached out to Metamask Support, but it has been three days and no answer.

Hi, Most probably your funds are not lost but perhaps you have not added proper network into metamask wallet. I can look into it if you can provide your wallet address.

Hey @Stephenschreck123457, thanks for reaching out to the support team, they will be with you as soon as they can!

Tokens cannot be sent directly from network to network, they must be transferred using a bridge. Swapping tokens only swaps them on the same network, so your ETH is still on BSC.

Make sure you have imported the correct contract address for ETH on BSC. If you are still having issues, would you be able to send your transaction hash? That would provide more helpful information.

1 Like

Thanks so much for the reply! I think that is the problem as well.

I imported the contract address it is showing. But when I click on ETH in the BSC, it is still showing m address as the same one as ADA and BNB. So I think I messed up somewhere. Any tips on how to import it correctly would be amazing!

Here is the transaction hash - 0xca2703bf1b48d86cb9569d6eddd8887c5c25ec1b81dd3f2dc51116ac7ee01ee9

Hi @Stephenschreck123457 ,
Yeah I checked your provided transaction hash, you have the coins (actually tokens binance pegged) into your wallet, you can send them out by using BNB network. Please note that you must be using BNB network to see your tokens/coins on BNB chain. Moreover you must have BNB to pay the gas fee to send your transaction.
About having the same address of ETH as BNB it is normal. In the same wallet a exact same address can be used and is available for both coins i.e for ETH and for BNB. So you should not worry about it and just use it normally.

1 Like

Thanks for the reply! Glad to hear that the tokens are there. But I cannot see them. My ETH Token wallet on the Smart Chain is empty. See pictures below.

It looks like it sent them to an ETH address that is not mine. And I am not sure how to add that address. Last picture. How can I get to them. Sorry. I am so confused.

hi @Stephenschreck123457
if my answer has solved your problem then please click on my comment and choose the solution option.

Thanks it was helpful. But hasn’t totally solved it. I just replied above what what I am seeing.

1 Like

Would you like to post your wallet address here from which you swapped to ada?

1 Like

It swapped to ADA fine. But when I swapped form ADA to ETH is where the problem happened. Don’t really want to post the wallet address to where the funds where sent. I just need to know how to get into that wallet as it is not in ether of my metamask accounts.

The address is the meta mask swap router - 0x1a1ec25DC08e98e5E93F1104B5e5cdD298707d31

So the funds went there? And never came back?

okay, I understand and it is fine if you are not comfortable sharing your wallet address. I will suggest you switch to the ETH network in the same MM wallet and then check there if you can see the ADA if not try to add tokens manually there I hope you will see your tokens there and from there you can swap back or send them to exchange etc.

Hey procrypto. I shared it above. It is the Meta Mask Swap Router. - 0x1a1ec25DC08e98e5E93F1104B5e5cdD298707d31

So the funds went there? And never came back?

I have switched to the ETH Mainnet in the same wallet. I have Added both ADA and ETH token there as well. And still nothing.

I don’t know what to do! Thanks for all the help though.

Try to import your wallet into trust wallet/safe pal wallet or any other supported wallet and see if it shows there?

Your ETH on BSC is in the same wallet address that you have done the swap transaction with.

Please make sure you have added the correct contract address for ETH on BSC :point_down:


AMAZING! That worked. I must have been using the wrong Contract address! Thanks!


This topic was automatically closed after 30 days. New replies are no longer allowed.