App Breaking Bug


I just wanted to let you know about this app breaking bug. It has now happened twice on the newest Android version of MetaMask only my Note 20. There is a “Transaction submitted” prompt that gets stuck at the bottom of the screen in the browser that never goes away. It makes it impossible to use any of the functions that the notification is covering. It also makes things in that area of other menus unusuable too (wallet, settings) even though I can’t see it in those menus. Everything below is unusable. This makes connecting MetaMask to any sites impossible, and you are unable to approve transactions. I’ve been to every option in every menu and cannot get rid of it. I have tried clearing cache of the app and restarting the phone. The only solution is to uninstall the app and reinstall it, and log back in. This isn’t acceptable because it takes so long to add all of the custom networks I have, as well as the contract addresses for all of the custom tokens. I’ve attached a couple pictures for reference. Does anyone have any ideas on how to fix it? Again, I don’t want to have to uninstall and reinstall the app every time this happens, as it happens often.



Update: Logging out and logging back in fixed it the second time, but not the first time.

! Screenshot_20210411-083238_MetaMask|253x500