Approved transaction, but no transaction

I tried to purchase a token from Indexed (a site offering tokens that are basically crypto ETF’s). I linked my MetaMask wallet to the website successfully, and attempted to buy a token using USDC. The transaction was processed and completed over 6 days ago according to etherscan, but I still have ALL my USDC still in my wallet, and I do not have the token I purchased (or so I thought) in my wallet… what happened? Can I use my USDC still in my wallet to make another transaction?

Please provide your transaction ID to check if you actually bought the ETF or not, sometimes when you try to buy from a new swap or store you first have to give permission to the store to make transactions on your wallet so maybe you accepted that but not the actual order??

im having this issue everyone i try to send anything to from my meta mask just says it goes through and endlessly does pending transaction how do i fix this it worked well like 2 months back

Are you able to see these transactions on a block explorer like etherscan.io?